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Cette FAQ a été réalisée a partir des questions fréquemment posées sur les forums de
www.developpez.net/forums et de |'expérience personnelle des auteurs.

Nous tenons a souligner que cette FAQ ne garantit en aucun cas que les informations
qu'elle propose sont correctes. Les auteurs font leur maximum, mais l'erreur est
humaine. Cette FAQ ne prétend pas non plus étre compléte. Si voustrouvez une erreur,
ou que vous souhaitez nous aider en devenant rédacteur, lisez Comment participer a
cette FAQ 2.

Sur ce, nous vous souhaitons une bonne |ecture.

L'équipe Java/Eclipse
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Sommaire > Informations

Comment te FAQ

Auteurs: L'équipe Eclipse,

Lebut: Cette FAQ aééconguepour étrelaplussimplepossibled'utilisation. Elletented'apporter desréponsessimples
et complétes aux questions auxquelles sont confrontés tous les débutants (et les autres).

L'organisation : Les questions sont organisées par théme, les thémes pouvant eux-méme contenir des sous-thémes.
Lorsgu'une question porte sur plusieursthémes, celle-ci est insérée dans chacun desthéemesrendant la recherche plus
facile.

Lesréponses : Les réponses contiennent des explications et des codes sour ces. Certaines sont complétées de fichier a
télécharger contenant un programme de démonstration. Ces programmes sont volontairement tres simples afin qu'il
soit aisédelocaliser le codeintéressant. L esréponses peuvent également étr e complétéesdeliensversd'autresréponses,
versla documentation en ligne de Sun ou versun autre site en rapport.

Lesversions: Lorsqu'une question n'est pertinente que pour certainesversion du logiciel, ou lorsque laréponse varie
selon la version, une étiquette est placée a gauche de la question. Cette éiquette indique la ou les ver sions concer nées :
Par exemple:

[3.2] Concernelaversion 3.2.

. [3.0-] Concernelesversions 3.0 et antérieures.

. [3.x] Concernetouteslesversions mineuresdelaversion 3.
[3.4+] Concernelaversion 3.4 ainsi que les versions suivantes.

Nouveautéset misesajour : Lorsdel'ajout ou delamodification d'une question/r éponse, un indicateur est placéacoté
dutitredelaquestion. Cet indicateur restevisible pour uneduréede 15joursafin devous permettredevoir rapidement
les modifications appor tées.

J'espére que cette FAQ pourra répondre a vos questions. N'hésitez pas a nous faire part de tous commentaires/
remarques/critiques.

lien : FAl Comment participer a cette FAQ ?

 remdens |

Auteurs: L'équipe Eclipse,

Un grand merci atous ceux qui ont prisde leur temps pour laréalisation de cette FAQ.
Aux rédacteurs: Remerciementstout d'abord atous ceux qui ont rédigé les questions et lesréponses.

Aux correcteurs : Remerciements également aux personnes qui ont relu les textes pour supprimer un maximum de
fautes defrancais.

Aux visiteurs: Remerciements enfin a tous ceux qui ont consulté cette FAQ, et qui, par leursremarques, nousont aidé
alaperfectionner.
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Et pour finir, un merci tout spécial a tous les membres de I'équipe qui nous ont fourni outils et logiciels nécessaires
pour laréalisation de ce document.

Auteurs: L'équipe Eclipse,

L esressour ces disponibles sur Developpez.com :
' ﬂLescoursettutorieIsEclipse
ﬂLesforums Eclipse

WA arAQEdipse

ﬂ LesBlogs Eclipse

L esressour ces disponibles sur le Site Officiel d'Eclipse:

“Eclipse.org

“Les plug-ins et applicationsréférencés sur Eclipse Marketplace
“ Eclipse Live (Webinaires, Podcasts, Démos, ...€tc).

ﬁLe Bug Tracker desProjets Eclipse

ﬁLebIog Planet Eclipse

B8 L e Wiki Eclipse

Bl | esitede téléchargement dela version courante avec toutes ses déclinaisons selon le type de dével oppement
guel'on veut faire.

“ EclipseIndigo (3.7) et “ L es nouveautés significatives
“ Eclipse Helios (3.6) et “ L es nouveautés significatives
=] Eclipse Galileo (3.5) et B L es nouveautés significatives
B Eclipse Ganymede (3.4) et B L es nouveautés significatives
H Eclipse Europa (3.3)

Comment participer acette FAQ ?

Auteurs: L'équipe Eclipse,

Cette FAQ est lefruit d'une collaboration et tout le monde peut y participer.

Vous pouvez déposer vos remar ques, suggestions ou améliorationsici.

Si vous souhaitez intervenir plus intensément, voici plusieurs compétences actuellement recherchées pour améliorer
cette FAQ :

Rédacteur : Bien évidemment, toute nouvelle question/réponse est la bienvenue.

Web designer : Toute per sonne capable de faire une meilleure mise en page, une feuille de style ou de bellesimages...
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Correcteur : Malgré nos efforts, desfautes d'orthographe ou de grammair e peuvent subsister. Merci delessignaler ici
si vous en débusquez... Idem pour leslienserronés.

lien : FAl Quels sont lesdroits de reproduction de cette FAQ ?

uels sont les droits de reproduction de cette FAQ ?

Auteurs: L'équipe Eclipse,
L es codes sour ces présentés sur cette page sont libres de droits, et vous pouvez les utiliser a votre convenance. Pour le

reste, ce document constitue une oeuvr e intellectuelle protégée par lesdroits d'auteurs.
Copyright © 2009 Developpez LLC : Tousdroitsréservés Developpez LL C. Aucunereproduction ne peut en érefaite
sans|'autorisation expresse de Developpez L L C. Sinon vous encour ez selon laloi jusgu'a 3 ansde prison et jusqu'a 300

000 E de dommages et intér éts. Cette page est déposée ala SACD.
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Sommaire > L'EDI Eclipse

ce que Eclip

Auteurs: Lunatix , djo.mos, Laurent.B,

Eclipse est un EDI (Environnement de Développement Intégré), ou en anglais un IDE (Integrated Development
Environment).

Développépar IBM apartir desesancétres Visual Ageet Visual Age For Java, il adepuisétérendu open-sour ce et son
évolution est maintenant gérée par la “ Fondation Eclipse.
Cettefondation est composée d'un grand nombredeﬁ membres et est dirigée par un ﬁconseil d'administration.

Sa conception est complétement modulaire: baséesur desnotionstellesque” micronoyau H OSGi " (depuislaversion
3) ou encoreles plug-ins, ce qui fait d'Eclipse une boite a outils facilement modifiable et extensible.

Lalicensed'Eclipse (ﬁ Eclipse Public License et sa“ FAQ) permet defournir des plug-ins open sour ces comme deg
plug-ins closed-sour ce, des plug-ins gratuits ou encor e payants.

C'est pourquoi il est maintenant bien plusqu'un IDE Java, et gére un FAll Quels sont leslangages que peut gérer Eclipse
en plusde Java ? telsque PHP, C, C++, etc.

Eclipse est également devenu une plate-forme, servant de socle a d'autres applications, que celles-ci soient destinées au
développement logiciel ou atout autre domaine.

Cette plate-forme est nommée 4l Qu'est ce que Eclipse RCP 2.
En consultant la pageﬁ Eclipse Marketplace vous aurez un aper ¢u des outils et solutionstournant autour d'Eclipse.

lien : FAl Quels sont leslangages que peut gérer Eclipse en plusde Java ?

Ou trouver Eclipse ?

Auteurs: Lunatix , djo.mos, Laurent.B,

Sur le site officiel “www.eclipse.org et plus précisement dansla section téléchargements: B Eclipse downloads

Laversion officielleen coursa cejour (27/02/2012) est Eclipse Indigo 3.7.2.
Voici le calendrier desversions simultanées : uhttp://wiki.eclipse.org/SimuItaneous_ReIease

Eclipse est décliné pour les plates-for mes Windows 32/64 bits, Mac 32/64 bits et Linux 32/64 bits.

Eclipse | DE for Java Developersest la version packagée pour faire principalement du développement en langage Java
J2SE.

Cependant, d'autres packages sont également disponibles afin de démarrer rapidement dans les domaines ou les
langagestels que Java EE, C/C++, Eclipse RCP, M odeling, Reporting, PHP...

Ces packages sont lerésultat d'un assemblage cohérent de plug-ins et évitent ainsi de faire soit-méme|'ajout des plug-
ins nécessairesvia I'update manager .

Théoriquement, on peut partir d'uneversion Classic et lacompléter avec lesdifférentsplug-insquel'on juge utiles pour
son propre besoin. De ce fait, on peut ajouter sur une méme installation d'Eclipse, I'ensemble des plug-ins nécessair es
pour faire a la fois du PHP, C/C++, Java/JEE et autres,... Néanmoins, il est préférable de rester raisonnable et de
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n'installer les pluginsqu'au fur et a mesure que vos besoins évoluent. Vous éviterez ainsi d'alourdir le fonctionnement
d'Eclipse et vousréduirez les conflits potentiels de dépendances entre les ver sions de plug-ins.

Pour fairevotre choix sur un package Eclipse de base, consultez Ieﬁ tableau compar atif des différents packages.

Vous pouvez trouver les liens de téléchargement des différentes versions d'Eclipse dans ce ﬂ Post-1t dans le forum
Eclipse.

Auteurs: Jfrancoisb7 , djo.mos, Laurent.B,

Par défaut, seulelalangue anglaise est disponible dans Eclipse. Néanmoins, le projet Babel B http://babel.eclipse.org/
babel/ est uneinitiative qui tente de per mettre, al'aide de plugins supplémentaires, la configuration del'interface dans
différentes langues, notamment le francais.

Voici les adresses des update-sites spécifiques aux différentes versionsd'Eclipse :

. Indigo : http://download.eclipse.or g/technology/babel/update-site/R0.9.1/indigo

. Helios : http://download.eclipse.or g/technology/babel/update-site/R0.9.1/helios

. Galileo : http://download.eclipse.or g/technology/babel/update-site/R0.9.1/galileo

. Ganymede : http://ar chive.eclipse.or g/technology/babel/update-site/R0.8.1/ganymede
. Europa: http://ar chive.eclipse.or g/technology/babel/update-site/R0.8.1/eur opa

Attention ! Ces URL ont de facheuses tendances a évoluer, donc n'hésitez pas a consulter cette page Ehttp://
www.eclipse.or g/babel/downloads.php.

Et pour lesversions archivées, c'est iCi E http://www.eclipse.or g/lbabel/ar chives.php.

Silalocalisation devotre OSest déjadanslalanguedanslaquellevoussouhaitez utiliser Eclipse, il voussuffit en principe
delancer simplement Eclipse et le bon pack de langue sera automatiquement chargé.

Si toutefois ce n'était pas le cas, ajoutez simplement le parameétre -nl fr dans le raccourci qui vous permet de lancer
Eclipse.

Veuillez noter ces quelques remarques a propos de Babel :

. Leprojet Babel éant géréapart desversionsd'Eclipse, il est normal que celui-ci ne soit pas souvent a niveau par
rapport aladerniéreversion en vigueur. Par exemple, au moment delarédaction de ceslignes, laversion officielle
en vigueur d'Eclipse est Helios SR2 et donc, la version de Babel n'est adaptée qu'a la version Helios SR1. Pour
autant, cela ne doit pas vous empécher d'installer une version Babel Helios SR1 sur une version d'Eclipse Helios
SR2. Simplement, vous noter ez sans doute par-ci, par -la quelqueslibellés en anglais, au lieu d'étre en francais.

. Leprojet Babel a parfoisdu mal a suivrel'évolution d'Eclipse et cela est sansdoutelié au fait qu'il faut du temps
et des ressources humaines pour synchroniser toutes les traductions. Donc, pour ceux qui ne peuvent pas sen
passer, soyez heureux que ce projet existe.

. Il arrive quel'installation ne se passe pas toujours sans probleme.

Si vous rencontrez des difficultés avec ce plug-in, sans doute mieux vaut-il ne pastrop sacharner. Le forum est
[a pour en témoigner.

Danscertainscas, il peut mémearriver que des plug-ins ne supportent pasdu tout une autrelangue quel'anglais,
soit parce qu'ils ne sont pas prévus pour étreinternationalisés, soit qu'ils contiennent desréférencesen dur ades
libellésanglais...

. D'autre part, mémessiil est plus agréable, car plussimple, d'avoir une interface dans sa langue, gardez a I'esprit
qu'il serabien plusfacile d'obtenir del'aide sur telle ou telle fonctionnalité, al'aide destermes originaux !
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Donc, a moins que I'anglais soit réellement un supplice pour vous, en conservant la version originale, au final vous
devriez gagner du temps.

En conséquence, méme si le forum developpez.com est un forum francophone, touteslesréférencesal'lHM d'Eclipse
sont données pour lestermes anglais uniquement !

lien : FAl [3.3-] Comment installer un plug-in ?
lien : FAQ [3.4] Comment installer un plug-in ?
lien : FAl [3.5] Comment installer un plug-in ?

Comment forcer Eclipse pour qu'il soit en anglais ?

Auteurs: Laurent.B ,

Si pour uneraison ou pour uneautre, vous étesen face d'uneinstallation d'Eclipse, dont I'interface n'est pasen anglais
et quevouspréféreriez que ce soit le cas, alor s ajoutez simplement -nl en dansleraccourci qui per met delancer Eclipse.

[2.x] Comment installer Eclipse sur ma machine ?

Auteurs: Lunatix ,

Décompressez |'archive d'Eclipse. Vaila, c'est fini, Eclipse est installé. Attention il a besoin d'un JRE (Java Runtime

Environment) pour fonctionner, voire d'un JDK si vousvoulez faire du développement Java.

Les petitsplus

. L'option -VM permet de spécifier le Runtime Java a utiliser

. Sous Linux, un lien symbolique (In -s) vers le répertoire jre de Java, dans le répertoire Eclipse, lui permet de
trouver |'environnement Java sans plus de configuration

[3.X] Comment installer Eclipse sur ma machine ?

IAuteurs: Lunatix , Laurent.B,

Apreés avoir récupéré un package Eclipse adapté a votre environnement et vos besoins (cf. fA Ou trouver Eclipse ?),
il suffit de le décompresser et celui-ci est immédiatement exécutable (via son fichier eclipse.exe). Ceci a la condition

d'avoir au moins uneﬁ Machine Virtuelle Java (JRE ou JDK) installée.
A noter que méme si Eclipse est exécutable directement a partir du répertoire décompressg, il est recommandé, voire
nécessaire, dele placer a un endroit classique proche delaracine, tel que sous Windows C:\Program Files.

Comme expliqué, Eclipse a besoin d'une JVM pour fonctionner (Java5 ou 6).

Donc, s vous comptez développer en Java, préférez I'installation d'un JDK au lieu d'un JRE. Vous bénéfierez ainsi
automatiquement dela Javadoc et du code source del'API Java Standard.

Certaines fonctionnalités, telles que la signature de fichiers jar, nécessitent qu'Eclipse ait été démarré a |'aide d'une
VM de JDK.

Si vous comptez utiliser Eclipse pour développer avec d'autres langages que Java, alorsun JRE devrait suffire.
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Cf. Fi Comment lancer Eclipse avec une autre JVM que celle par défaut ? pour un complément d'infor mations.

[2.X] Pourquoi deux versions pour Linux ?

Auteurs: Lunatix ,

Lalibrairie graphique utilisée par Eclipse (SWT) met en oeuvre I'API graphique du systéme d'exploitation (mfc sous
win32, cocoa sous macos) et Gtk ou Motif souslinux. C'est pourquoi voustrouver ez deux versions: uneversion Eclipse
Gtk, et une autre Eclipse Motif.

Pour information, il existe aussi uneversion QT non disponiblea causedelalicensede QT (GPL) €t il existe également

une version non officielle pour Fox ﬁ Eclipse Fox

Qu'est ce que Eclipse RCP ?

Auteurs: Lunatix ,

RCP : Rich Client Platform

Il sagit d'un framework de développement pour client riche sur lequel est basé Eclipse. En effet méme s Eclipse a été
principalement créépour éreun logiciel de développement, sa nature modulairelerend utilisable pour n'importe quel
type d'application.

Eclipse RCP est composé d'un conteneur OSGi (Equinox) ainsi que d'un ensemble minimal de plug-ins pour faire
fonctionner une application graphique (environ 13 Mo).

Lapagedu projet ﬁwiki.ecIipse.org/index.php/Rich_CIient_PIatform
Lesitedenewsliésa Eclipseﬁ PlanetEclipse.org

Des applications basées sur le RCP =] eclipse.or g/community/rcp.php
Notons enfin que comme pour SWT, il est possible de faire un projet commercial en utilisant RCP sansrien avoir a
payer.

Comment lancer Eclipse avec une autre VM que celle par défaut ?

IAuteurs: L'équipe Eclipse, Laurent.B,

Si un JRE ou un JDK est installé sur votre systéme, alors Eclipse peut théoriquement démarrer sans probléme.
Si vous avez plusieurs JRE/JDK installés sur votre systéme et que vous souhaitez qu'Eclipse démarre sur 1'un d'eux en
particulier, alors différentes possibilités s offrent a vous:

1) Il est possible de spécifier laVM al'aide del'argument -vm, suivi du chemin vers|'exécutable Java.

Exemple sous Windows : eclipse.exe-vm " C:\Program Files\Java\jdk 1.6.0\bin\javaw.exe"

A vous d'adapter en fonction de votre OS, et de I'emplacement de |'exécutable Java. Ceci fonctionne a la fois en ligne
de commande ou al'aidedel'icone qui sert alancer Eclipse.

2) L'argument -vm peut également étre spécifié danslefichier eclipse.ini.
Il doit cependant étreindiqué de cette maniére:

-vm
C:./ Program Fi | es/ Java/j dk1. 6. 0/ bi n/ j avaw. exe
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3) SousWindows, uneautresolution consisteacopier lecontenu d'un JRE installédefacon classique, dansun répertoire
nommeéjre, directement danslerépertoired'installation d'Eclipse.
Concrétement, I'arbor escence doit étre proche de ceci :

= ) edipse-3.4
|2) configuration
I2) dropins
| Features
=2 e
I Bin
1= lib
) p2
|2 plugins
1) readme

Sous Linux, le méme principe peut étreréalisé avec un lien symbolique (In -s) verslerépertoirejre de Java, donc sans
copier quoi que ce soit.

Eclipse n'est alors plus dépendant desinstallations/ désinstallations/ misesajour de JDK / JRE.

Ainsi, lorsdu démarrage, si rien n'est spécifié danslefichier eclipse.ini ou dansl'icone de lancement, alorslerépertoire
jresera automatiquement pris en compte.

Pour vérifier si tout est cohérent, unefois Eclipsedémarré, il suffit d'aller dansle menu Help > About Eclipse Platform
> Configuration Details et d'y chercher lesinformations ressemblant a ceci :

-vm
D:\ Program Fil es\eclipse-3.4\jre\bin\client\jvmdll

IAuteurs: Laurent.B,

Lorsgue I'on installe Eclipse, celui-ci est pré-configuré avec une certaine quantité de mémoire dont il peut disposer
pour son exécution.

Comme cet IDE est basé sur Java, il a naturellement hérité des paramétres standards pour I'allocation de mémoire
d'une application Java, c'est-a-dire Xmx et Xms.

De fait, il est notamment possible de configurer ces deux paramétres au sein du fichier eclipse.ini (présent dans le
répertoireracine devotreinstallation d'Eclipse).
Le plusimportant est le paramétre de la mémoire Xmx. Donc, lorsque cela s'avére nécessaire (si par exemple Eclipse
commence a indiquer qu'il n'a plus assez de mémoire), vérifiez que le paramétre Xmx n'est pas plafonné a 256m ou
512m, car ce sont des quantités de mémoir e relativement basses (mais néanmoins suffisantes dans bien des cas).
Par exemple, mettez la valeur suivante:

- Xnx768m

ou davantage s nécessaire

- Xmx1024m

En respectant bien le formalisme et également en plagant ce par amétre aprés -vmar gs.
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Lamémoire Xmsest la mémoire initiale. Si vous avez suffisamment de mémoire pour allouer la totalité dela mémoire
Xmx, alor svouspouvez mettreunevaleur identique pour Xmx et Xms. Procédez comme pour lamémoire Xmx, indiquez
la valeur qui vous convient.

Par exemple comme ceci :

- Xms768m
En revanche, vous ne pourrez pas avoir une valeur Xms supérieure a celle de Xmx.

Si vous n'avez pas assez de mémoire vive, voire si vous avez atteint un maximum (en fonction de I'OS), Eclipse ne
démarrera pas et affichera une fenétre de rapport d'erreur. A ce moment-1a, réduisez la quantité de mémoire Xmx,
jusqu'a ce que ¢a passe. Vous avez la possibilité de mettre des valeurs arbitraires, il n'est pas utile de respecter les
exposants de 2.

A noter que vous pouvez utiliser ces mémes paramétres via la ligne de commande ou dans un raccour ci, par exemple
de cette maniére:

ecl i pse. exe -vmargs - Xmx400m - Xns400m
Vous pouvez contrdler votre paramétrage, une fois Eclipse démarré, en affichant le moniteur de mémoire. Cette

opération est expliquée dans cette FAl Comment récupérer delamémoirelorsqu'Eclipsearrivealalimite de sa mémoire
allouée?

IAuteurs: Laurent.B ,

Depuisbien desversions, Eclipse sait nous prévenir, théoriquement, lorsquela limite de sa mémoir e allouée est bient6t
atteinte. Ceci alegrand avantage d'éviter de perdre ce qui n'a pas encor e été sauvegar dé (des suitesd'un plantage sec),
voiredelibérer dela mémoire afin derevenir a un niveau moinscritique.

Pour libérer la mémaire, il y a une premiére astuce simple qui consiste a fermer des vues, éditeurs ou per spectives.
Cependant, en procédant ainsi, on peut également perdre un certain contexte et donc cela peut étre potentiellement
génant.

Intervient alorslapossibilité de provoquer le Gar bage Collector (ramasse-miettes), lequel va bien souvent pouvoir nous
dépanner, en évitant d'avoir aredémarrer Eclipse.

Pour exécuter le Garbage Collector, il faut préalablement avoir activé le moniteur de mémoire, via le menu Window >
Preferences > General, puis en cochant la case Show heap status.

Unefoiscelle-ci activée et aprésavoir cliqué sur OK, on peut voir apparaitre (en basa droite en principe), le moniteur
de mémoire. Il nereste plus ensuite qu'a cliquer sur le petit icone de la poubelle, & droite de celui-ci.

On peut déclencher plusieurs fois le Garbage Collector car parfois cela permet de libérer davantage de mémoire.
Cependant, il se peut également que la mémoire ne désemplisse pas et il faut alors tout de méme penser a fermer un
éditeur ou toutevue ou élément dont on sait, ou I'on devine, qu'il va pouvoir restituer delamémoire. Quittealerouvrir
juste aprés.

Voici a quoi ressemble le moniteur de mémoireﬂ_“Wﬂﬁ
Vous constater ez que la mémoir e totale affichée est toujoursinférieure ala mémoire par amétr ée (sic).
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Lorsguela mémoire arrive a saturation, vous pourrez constater que la zone devient rouge. Sur certaines opérations, il
arrive que le seuil maximum soit atteint, sans pour autant provoquer de probléme. Unefois|'opération gour mande en
mémaoir e, terminée, la zone redevient orange. Si ce n'est pas le cas, alors aidez-vous du Garbage Collector pour faire
redescendre le niveau.

Qu'est-ce qu'un workspace ?

Auteurs: Lunatix , djo.mos,

Il sagit de lI'espace de travail : quoi vous aviez deviné ? Plus précisément, c'est un répertoire dans lequel vous allez

pouvoir créer vos projets, qu'ils soient Java ou autres. Tous les fichiers manipulés par Eclipse se trouvent dans ce

répertoire. Bien slir, vous pouvez disposer de plusieurs workspaces, dans lesquels vous pourrez regrouper vos projets

comme vous le souhaitez.

. Avoir trop de projetsouverts peut ralentir Eclipse

. Copier/Coller un workspace suffit généralement a le déplacer. Ceci autorise donc la sauvegarde, le déplacement
d'un postea un autre, d'emmener son boulot sur uneclé USB, ...

Notez que Eclipse et plusieurs plug-ins utilisent le wor kspace pour y stocker des parameétres de configuration dans un

sous-dossier caché .metadata.
Ainsi, effacer cedossier ou démarrer Eclipse avec |'option -clean va supprimer ces paramétres.

Comment définir un répertoire différent pour mon workspace ?

Auteurs: L'équipe Eclipse,
Depuislaversion 3.0, Eclipse demande a chaque démarrage quel répertoire utiliser en tant que Workspace. Unefaisle
démarrage terminé, vous avez la possibilité de basculer sur un autre Workspace en allant dansle menu File > Switch
wor kspace.

Vous pouvez aussi, depuis Eclipse 2, spécifier un répertoire particulier par I'intermédiaire del'option -data.

Célle-ci peut étre spécifiée en ligne de commande de la maniér e suivante : eclipse -data " c:\dev\eclipse-wor kspace-2"
Vous pouvez également paramétrer un icbnedemaniéreacequ'il ouvre Eclipseavec lebon Workspace. Leprincipe est
exactement le méme qu'en ligne de commande et il suffit de préciser le paramétre -data suivi du répertoire workspace
souhaité, au niveau dela cible de lancement.

Qu'est ce qu'une Perspective, une View ou un Editor ?

IAuteurs: Lunatix , Laurent.B,

Contrairement a un grand nombre d'applications, Eclipse n'est pas basé sur MDI (Multi Document | nterface), mais
sur un systéme différent qui lui est propre: les Perspectives.

Une per spective est un ensemble de vues qui permet detravailler sur un théme donné.

On a par exemple |la perspective Resource qui permet de voir tout ce que contient le workspace, la per spective Java
pour développer en Java, la perspective CVS pour gérer sesrepositories, la perspective Debug pour le débogage, ...
Ces perspectives sont accessibles via la petite barre d'outils qui se trouve en haut a droite (par défaut)

L@t Raas

L esvues(ou views) sont desfenétresgraphiquesd'Eclipse qui per mettent d'afficher desinfor mations: unevue" Package
Explorer" vapermettredevoir lespackagesJavadu projet, unevue CVSHistory pour afficher I'historiqued'un fichier
sous CVS, ...etc.
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La plupart des plug-ins ajoutent des perspectives (par exemple une per spective base de données pour QuantumDB)
composées de vues (Table Explorer) Les plug-ins les plus petits n'ajoutent parfois que des vues comme le plug-in
TreeHistory qui ajoute une vue graphique (alaWinCVS) pour CVS.

Il est possible de customiser les perspectives : pour ouvrir par exemple une vue CV S repositories dans la per spective
Java, il suffit d'ouvrir la perspective Java et de faire : Window > Show View et sélectionner la vue que I'on veut en
plus. Cette modification est permanente. Cela vous per met donc de customiser les per spectives que vous utilisez et de
CONSEr Ver Ces parametres.

Reset Per spective : vousétesallétrop loin, lavue Ruby ouvertedansla per spective JavaentrelavueCVSet lavueTable
Explorer de Quantum DB, cen'est plus possible. Window > Reset Per spective... et voila la per spective Java comme au
premier jour.

[2.x] Comment sauvegarder ses préeférences ?

Auteurs: L'équipe Eclipse,

Allez dansle menu Window > Preferences, cliquez sur le bouton Export (en bas a gauche), puis choisissez ce que vous
voulez sauvegarder.

Pour lesréimporter, allez dansle menu Window > Preferences, cliquez sur le bouton Import (en bas a gauche)

[3.x] Comment sauvegarder ses préférences ?

IAuteurs: Laurent.B ,

Eclipse permet d'exporter ses préférences dans un fichier et de les re-importer ensuite dans une autre installation
d'Eclipse.

Pour exporter les préférences dans un fichier, procédez comme suit :

Allez dansle menu File > Export.

Sélectionnez General > Preferences puis cliquez sur Next.

Sélectionnez les éléments qui vousintéressent.

Indiquez un emplacement et un nom defichier d'export en cliquant sur Browse....

Terminez en cliquant sur Finish

ab~h wdNE

Pour importer les préférences a partir d'un fichier, procédez comme suit :
Allez dansle menu File > Import.

Sélectionnez General > Preferences et cliquez sur Next.

Cliquez sur Browse... et indiquez I'emplacement du fichier aimporter.
Sélectionnez les éléments qui vousintéressent.

Cliquez sur Finish.

ab~h wiNE

lien : FAl Comment sauvegarder ses configurations d'exécution et ses pointsd'arrét de debug ?

Comment sauvegarder ses configurations d'exécution et ses points d'arrét de debug ?
Auteurs: Laurent.B,

Pour sauvegar der les configurations de lancement de vos projets, procédez comme sulit :

. Allez dansle menu File > Export... > Run/Debug

. Séectionnez Launch Configurations puis cliquez sur Next

. Renseignez I'emplacement du répertoire ou vont étre créés vos fichiers de configuration (1 fichier .launch par
projet).

. Cliquez sur Finish
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Pour importer des configurations de lancement, procédez comme suit :

. Allez dansle menu File > Export... > Run/Debug

. Sélectionnez Launch Configurations puis cliquez sur Next

. Renseignez |'emplacement du répertoire ou sont présents vos fichiers de configuration de lancement (dont
I'extension est .launch).

. Sélectionnez lesfichiers qui vousintéressent, puis cliquez sur Finish

Le principe est identique pour I'import et I'export de Points d'Arrét (Breakpoints). Les fichiers de Breakpoints
comportent quant a eux I'extension .bkpt.

Comment utiliser Ant avec Eclipse ?

IAuteurs: christophel , Laurent.B,

Eclipseintégre par défaut un plug-in Ant.

Pour étresir qu'il est bien installé, si vous n'avez pas de fichier nommeé build.xml déja présent dans un projet, créez-
en un et ouvrez-le.

L'ouverturedecefichier entraineen principel'activation d'un éditeur XML spécifiqueaAnt, lequel per met notamment
I'auto-complétion relative a ce dernier.

Pour exécuter lefichier build.xml avec Ant, il suffit defaireun clicdroit sur lefichier, puisde sélectionner lemenu Run.
Il est également possible, aprés avoir sélectionné le fichier, de passer par le menu Run > External Tools > Run as >
Ant Build.

D'autrepart, s vousavez lavue Ant ouverte, faitesglisser votrefichier al'intérieur afin que celui-ci soit prisen compte.
Vous pouvez ainsi exécuter treés facilement des taches particuliéres, si ce n'est pas la tache par défaut dont vous avez
besoin.

Si votrevue Ant n'est pas ouverte, alorsouvrez-la al'aide du menu Window > Show View > Other... > Ant > Ant.

Ou trouver I'aide d'Eclipse ?

IAuteurs: Jfrancoiss7, Laurent.B ,

Eclipse intégre théoriquement sa propre documentation. Elle est accessible par le menu : Help > Help Contents.
D'autre part, il existe une documentation accessible en ligne pour lesversions suivantes:

* Indigo (3.7) : ﬁ http://help.eclipse.or g/indigo/

Helios (3.6) : B http://help.eclipse.or g/helios/

Galileo (3.5) : ﬁ http://help.eclipse.or g/galileo/
Ganymede (3.4) : ﬁ http://help.eclipse.or g/ganymede/
Europa (3.3) : ﬁ http://help.eclipse.or g/help33/

Quelles sont |es options de lancement de Eclipse ?

IAuteurs: Laurent.B ,

Eclipse autorise un certain nombre d'options destinées a paramétrer son lancement.
Laliste est assez longue et permet de préciser par exemple, les arguments de la machine virtuelle, le workspace cible,
['activation du mode debug, le nettoyage du cache, la localisation et bien d'autres.

La liste des options de lancement d'Eclipse est décrite dans la documentation, accessible par le menu Help > Help
Contents, puislarubriqgue Workbench User Guide > Tasks > Running Eclipse.
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Comment basculer en mode sélection de bloc ?

IAuteurs: Laurent.B ,

L'éditeur d'Eclipse propose un mode de sélection/édition en forme de bloc rectangulaire, qui peut savérer treés utile
dans certaines cir constances.

Comme c'est un mode de fonctionnement, il faut |I'activer/désactiver al'aide du raccourci ALT + SHIFT +A.
Ainsi, lecurseur est transforméen croix et autorise la sélection de maniére graphique, d'une zone de texte.

L'utilité principale de cette fonctionnalité est qu'il est alors possible de modifier en colonne, le texte sélectionné. Cela
peut remplacer, de facon assez appr éciable un " rechercher/remplacer” .

Uneautreutilisation, est de facilement récupérer un bout de code, sansrécupérer touslescaractér es présentsen amont,
afin par exemple de le copier/coller dansun post, sur le forum developpez.com.

Voici en apercu de lafagon dont ¢a se présente:

Sélection
private static woid roundValueToTwolecimals|(
{
int i = 1;
Bystem. out.printly{i++ + " : " + Math.round(0.00 * 100f) / 100£):
Bystem. cut.printly(i++ + ™ : " + Math.reound(0.01 * 100£) / 100£);
Byatem. out.printly(i++ + ™ @ " + Math.round(0.051 * 100f) / 100f):
Eystem. cut.princly(i++ + ™ @ " + Math.round(0.054 * 100f) / 100f);
Bystem. out.princly(i++ + ™ : " + Math.round(0.055 * 100f) / 100f):
Bystem. out.printly{i++ + ™ : " + Math.round(l1.01111 * 100f) / 100f):
Byatem. cut.princly(i++ + ™ : " + Math.round(1.04111 * 100£f) / 100f):
Bystem. out.printly{i++ + ™ : " + Math.round(1.05111 * 100£f) / 100£f):
Bystem. cut.princly{i++ + ™ : " + Math.round(l1.054111 * 100f) / 100£):
410
System. out.printlnii++ + " : " + Math.round{1.05499 * 100f) / 100f);
System. out.printlnf{i++ + ™ : " + Math.round(l.05511i1 * 100f) / 100£):
Iystem. cut.princtlnii++ + ™ : " + Math.round(l.056111 * 100£) / 100£):
M odification

private static void roundValueToTwoDecimals ()
{

int i = 1:

Jog.debugl{i++ + ™ : " + Math.rouwnd(0.00 * 100£) / 100f):
Jog.debugl{i++ + " : " + Math.round(0.01 * 100£) / 100f):
Jog.debugl(i++ + ™ ¢ " + Math.reouwnd(0.051 * 100£f) / 100£);
Jog.debugl(i++ + ™ ¢ " + Math.round(0.054 * 100f) / 100f):
Jog.debugl{i++ + ™ ¢ " + Math.reownd(0.055 * 100f) / 100f):
Jog.debugl(i++ + ™ : " + Math.rownd(1.01111 * 100f) / 100£):
Jog.debugl{i++ + ™ : " + Math.round(l1.04111 * 100f) / 100£f):
Jog.debugl(i++ + ™ : " + Math.rownd(1.05111 * 100f) / 100£):
Jog.debuglii++ + ™ : " + Math.round(1.054111 * 100f) / 100f):

#4010

SIystem. out.println(i++ + "™ ¢ " + Math.round(1.05499 * 100f) / 100£f):
Iystem.out.println{i++ + ™ : " + Math.rownd(l1.055111 * 100f) / 100f):
System.out.println{i++ + ™ : " + Math.round(l.056111 * 100f) / 100f):

| Lesraccourcis claviers indispensables |

Auteurs: L'équipe Eclipse, Laurent.B ,

Quelquesraccourcis clavier indispensables sous Eclipse (uniquement la configuration standard, non emacs).
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Lesraccourcis classiques que tout le monde connait ne sont pas évoquésici (CTRL +V,CTRL +S,..)

Raccour cis clavier

. CTRL + SHIFT + L : Affichelaliste desraccourcis

. CTRL + Espace: L'indispensable auto-complétion

. CTRL + SHIFT + O : Organize Imports

. CTRL + SHIFT + R : Recherched'un fichier dansle workspace

. CTRL + SHIFT + T : Rechercher une classe dans le workspace (indispensable s'il on a beaucoup defichiers)

. CTRL + O : Affichage des attributs et méthodes de la classe courante

. CTRL + O unedeuxiemefois : Ajoute al'affichage les attributs et méthodes héritées

. CTRL + T : Affichel'arborescence d'héritage de la classe cour ante

. ALT + SHIFT + J : Génére un template de javadoc pour une classe une méhode ou un attribut en fonction de
la sélection

. CTRL + SHIFT + F : Mise en forme du code (vous pouvez surligner une zone de code pour restreindre le
formatage)

. CTRL + SHIFT +1 : Indentation du code (vous pouvez surligner une zone de code pour restreindrel'indentation)

. CTRL + D : Effacelaligne courante

. ALT + SHIFT + R : Renommer une variable, une méhode ou fonction, une classe... etc (depuis 3.3 la
transformation peut sefaire en tempsrédl)

. CTRL + SHIFT + C: pour commenter / décommenter leslignes sélectionnées (commentair e encapsulant chaque
ligne indépendamment)

. CTRL + SHIFT + /: pour commenter / décommenter un blocs de lignes sélectionnées (peut avoir le méme
comportement que Ctrl+Shift+C selon le contexte)

. CRTL + SHIFT + P : Pour sedéplacer d'une accolade al'autre

. CTRL +K et CTRL + SHIFT + K : Positionne le curseur sur I'occurence suivante ou précédente de la sélection
de départ (attention réagit en fonction du paramétrage courant de larecherche avec Ctrl + F)

Evidemment, il y en a plein d'autres mais mieux vaut-il retenir au moins CTRL + SHIFT + L, car on a vite fait de
lesoublier.

Parfois, certainsraccourcis sont absents. Alorsil est possible de configurer soi-méme sa combinaison en allant dansle
menu Window > Preferences > General > Keys.
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Sommaire > Développement Java

Comment créer un projet Java ?

Auteurs: djo.mos,

Pour créer un projet Java, allez dansle menu File > New > Project... et localisez Java Project.
Dans|'assistant qui s affiche, saisissez un nom pour le projet a créer et cliquez sur Finish.

Lesraccourcis claviers indispensables
Auteurs: L'équipe Eclipse, Laurent.B ,

Quelquesraccourcis clavier indispensables sous Eclipse (uniquement la configuration standard, non emacs).

Lesraccourcis classiques que tout le monde connait ne sont pas évoquésici (CTRL +V,CTRL +S,..)

Raccour cis clavier

. CTRL + SHIFT + L : Affichelaliste desraccourcis

. CTRL + Espace: L'indispensable auto-complétion

. CTRL + SHIFT + O : Organize Imports

. CTRL + SHIFT + R : Recherched'un fichier dansle workspace

. CTRL + SHIFT + T : Rechercher une classe dans le workspace (indispensable s'il on a beaucoup defichiers)

. CTRL + O : Affichage des attributs et méthodes de la classe courante

. CTRL + O unedeuxiemefois : Ajoute al'affichage les attributs et méthodes héritées

. CTRL + T : Affichel'arborescence d'héritage de la classe courante

. ALT + SHIFT + J : Génére un template de javadoc pour une classe une méhode ou un attribut en fonction de
la sélection

. CTRL + SHIFT + F : Mise en forme du code (vous pouvez surligner une zone de code pour restreindre le
formatage)

. CTRL + SHIFT +1 : Indentation du code (vous pouvez surligner une zone de code pour restreindrel'indentation)

. CTRL + D : Effacelaligne courante

. ALT + SHIFT + R : Renommer une variable, une méhode ou fonction, une classe... etc (depuis 3.3 la
transformation peut sefaire en tempsrédl)

. CTRL + SHIFT + C: pour commenter / décommenter les lignes sélectionnées (commentair e encapsulant chaque
ligne indépendamment)

. CTRL + SHIFT + /: pour commenter / décommenter un blocs de lignes sélectionnées (peut avoir le méme
comportement que Ctrl+Shift+C selon le contexte)

. CRTL + SHIFT + P: Pour sedéplacer d'une accolade a l'autre

. CTRL +K et CTRL + SHIFT + K : Positionne le curseur sur I'occurence suivante ou précédente de la sélection
de départ (attention réagit en fonction du paramétrage courant de larecherche avec Ctrl + F)

Evidemment, il y en a plein d'autres mais mieux vaut-il retenir au moins CTRL + SHIFT + L, car on a vite fait de
lesoublier.

Parfois, certainsraccourcis sont absents. Alorsil est possible de configurer soi-méme sa combinaison en allant dansle
menu Window > Preferences > General > Keys.

Auteurs: zork ,

Pour générer automatiquemet les getters et settersd'une classe, il suffit defaire:
. Clicdroit sur la classe concernée (dans le Package Explorer ou |'éditeur Java), puis sélectionner le menu Source
> Gener ate Gettersand Setters
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Le menu est également accessible par leraccourci CTRL + SHIFT +S
Dans I'éditeur, vous pouvez surligner une variable afin que celle-ci soit présélectionnée dans I'assistant de génération
des getterg/setters.

[3.X] Comment générer les getters et setters d'une classe ?

Auteurs: djo.mos,

Pour générer automatiquemet les getters et settersd'une classe, il suffit defaire:
. Clic droit sur la classe concernée (dans le Package Explorer ou |'éditeur Java), puis sélectionner le menu Source
> Gener ate Gettersand Setters

Le menu est également accessible par leraccourci ALT + SHIFT + S
Dans I'éditeur, vous pouvez surligner une variable afin que celle-ci soit présélectionnée dans I'assistant de génération
des getter g/setters.

Comment placer facilement un point-virgule alafin de I'instruction ?
Auteurs: bobuse, Laurent.B,

Il faut configurer le positionnement automatique du point-virgule :

Allez dans le menu Window > Preferences > Java > Editor, dépliez typing et cochez Semicolons dans Automatically
insert at correct position.

Il suffit ensuite de taper un point-virgule et quelle que soit la position du curseur dans l'instruction courante, il sera
ajoutéalafin.

Comment aler d'une accolade al'autre ?

Auteurs: Lunatix ,

Pour aller d'une accolade { al'autre} vous pouvez utiliser leraccourci clavier CRTL + SHIFT + P
De plus un double-clic sur une accolade surlignetout le bloc jusqu'a I'accolade fer mante.

lien : FAll L esraccourcis claviersindispensables

Comment organiser mes imports ?

Auteurs: L'équipe Eclipse, Laurent.B ,

Lemoyen le plussimple est d'utiliser leraccourci CTRL + SHIFT + O sur lefichier Java en coursd'édition.
Ceraccourci est également applicable dans la vue Package Explorer, directement sur un package Java ou sur une
sélection multiple de fichiers Java (a condition que le(s) fichier(s) et/ou répertoire(s) fassent partie d'un répertoire
Sour ce).

Si la résolution automatique rencontre des homonymes, tels que java.util.List et java.awt.List, une boite de dialogue
vous demander a de sélectionner la bonne référence.

A noter quelaréorganisation desimports permet de déclarer explicitement chacune des classes (donc sans|'astérisque
'X.y.*"), tout en ajoutant celles qui n'auraient pas encore étéimportées.
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Laréorganisation trie également lesimports selon les packages et I'ordre alphabétique des classes impor tées.

lien : FAl Lesraccourcisclaviersindispensables

Comment gjouter un JAR amon projet ?

Auteurs: L'équipe Eclipse,

Pour ajouter un jar qui setrouve dansleworkspace:
. Clicdroit sur le projet, menu Properties > Java Build Path, onglet Librairies, puisbouton Add jar

Pour un ajouter un jar horsdu workspace:
. Clicdroit sur le projet, menu Properties> Java Build Path, onglet Librairies, puisbouton Add external jar

Comment gjouter des fichiers Java compilés'.class a mon projet ?

Auteurs: L'équipe Eclipse, Laurent.B ,

Pour ajouter un répertoire defichiers Java compilés'.class setrouvant dansle workspace:
. Clicdroit sur le projet, menu Properties > Java Build Path, onglet Librairies, puisbouton Add Class Folder

A noter quelaplupart du temps, lesfichiers.class sont packagés dansdesjarset donc ce sont lesjarsqui les possedent
qui doivent é&reimportés. Lesfichiers Java compilésd'un méme projet, n'ont a priori aucuneraison d'éreréférencés
par ce moyen-la. Cettefonctionnalité servira surtout si on a desfichiers.classqui viennent d'ailleurset dont les sour ces
auraient été perdusou qu'ils ne nous auraient pas été fournis.

[3.4] Comment gjouter des .class externes a mon projet ?

Auteurs: djo.mos, Laurent.B,

Pour ajouter un répertoire de .class (fichiers Java compilés) qui setrouve en dehors du workspace :
. Clic droit sur le projet, menu Properties > Java Build Path, onglet Librairies, puis bouton Add External Class

Folder

Cette solution ne s'appplique qu'a partir d'Eclipse Ganymede 3.4.

A noter quela plupart du temps, lesfichiers.class sont packagés dansdesjars et donc ce sont lesjars qui les possedent
qui doivent &reimportés. Lesfichiers Java compilésd'un mémeprojet, n'ont a priori aucuneraison d'étrer éférencés
par ce moyen-la. Cettefonctionnalité servira surtout si on adesfichiers.classqui viennent d'ailleurs et dont les sources
auraient été perdusou qu'ils ne nous auraient pas ééfournis.

Comment relier deux projets entre eux ?

IAuteurs: Laurent.B ,

LorsquedansEclipse, on a par exemple deux projetsA et B, ou A abesoin de B pour compiler et s'exécuter, il peut étre
intéressant de les mettre en relation de fagon explicite.

Pour référencer B au sein de A, il suffit defaireun clic droit sur le projet A, menu Properties > Java Build Path, puis
onglet Projects.

Ensuite, il faut cliquer sur Add... et sélectionner le projet B qui doit appar aitre dansla liste proposée.

Cetterdation doit étre a sensunique car B n'est pas censé avoir besoin de A pour fonctionner, ou alorsc'est qu'il y a
trés probablement un probléme d'ar chitectur e dans votre application.

-20-
L es sources présentées sur cette page sont libres de droits et vous pouvez les utiliser a votre convenance. Par contre, la page de présentation constitue une cauvre
intellectuelle protégée par |es droits d'auteur. Copyright ® 2010 Developpez LLC. Tous droits réservés Developpez LL C. Aucune reproduction, méme partielle,
ne peut étre faite de ce site et de I'ensemble de son contenu : textes, documents et images sans I'autori sation expresse de Devel oppez LLC. Sinon vous encourez
selon laloi jusqu'atrois ans de prison et jusqu'a 300 000 € de dommages et intéréts. Cette page est déposée ala SACD.
http://eclipse.devel oppez.com/fag/


http://www.developpez.com
http://eclipse.developpez.com/faq/
http://java.developpez.com/equipe/
http://java.developpez.com/equipe/
http://www.developpez.net/forums/u48115/laurent-b/
http://www.developpez.net/forums/u47389/djo-mos/
http://www.developpez.net/forums/u48115/laurent-b/
http://www.developpez.net/forums/u48115/laurent-b/

\) Peveloppez.com

Club der developpeuer

FAQ Eclipse

L'avantage principal qu'un projet A référenceun projet B, est tout simplement que cela évite :

. La compilation et le packaging (jar) du projet B pour pouvoir en faire usage dansle projet A. Les modifications
de B sont donc instantanément disponibles dans A.

. LaJavadoc del'API du projet B est implicitement disponible, ainsi que bien évidemment son code sour ce (inutile
de passer par CTRL + SHIFT + T pour aller ala déclaration d'une classe de B).

. Aucun par amétrage supplémentaire n'est en principe nécessaire pour exécuter A, le classpath est déa en phase.

Auteurs: L'équipe Eclipse, Laurent.B ,

. Clicdroit sur le projet, menu Properties > Java Build Path, onglet Librairies, puisbouton Add Library

UnelLibrary est a considérer ici comme un ensemble de bibliothégues (jars) prédéfini. Elle peut étre composéedesjars
nécessairesa une JRE, a un environnement JEE, a d'autres environnements spécifiques ou encor e, a un environnement
issu d'une User Library que vous pouvez composer vous-méme.

Auteurs: L'équipe Eclipse,

Pour utiliser les nouveautés de Java 5 (autoboxing, generics etc..) sous Eclipse, vous avez deux solutions:
. Utiliser Eclipse 3.1 ou supérieur
. Si vousavez uneversion antérieurea Eclipse 3.1, vous pouvez utiliser un plug-in qui gérelesnouveautésde Java 5.

Pour letéécharger, cf. ﬁ http://www.genady.net/forum/viewtopic.php?t=31.
Il faut ensuitel'installer en le dézippant dansle sous-répértoire plugins d'Eclipse et le configurer comme indiqué

ici B http://www.genady.net/forum/viewtopic.php?t=59

| Comment lier la Javadoc au JDK ou aunelib ? |

Auteurs: L'équipe Eclipse, Laurent.B ,

Un JRE (Java Runtime Environment) n'embar que pas la Javadoc ou les sources de I'API standard de Java, donc si
vous en avez besoin (ce qui est quasiment obligatoirelorsquel'on développe en Java), il faut avoir installé un JDK (Java
Development Kit). Unefois que c'est fait, vous pourrez constater la présence du fichier src.zip, lequel contient tous les
fichierssource (.java) del'API standard. Et defait, dans cesfichiers sour ce, vous aur ez également la Javadoc.

Donc, en référencant un JDK, automatiquement lefichier src.zip donne accés a la Javadoc. Concr étement, cela signifie
gu'en survolant les classes de I'API standard, ou en affichant la view Javadoc, vous devriez pourvoir visualiser la
Javadoc, voire méme d'ouvrir le code source de cette API (vialatouche F3 ou le CTRL + Clic gauche).

Si vousn'avez pasde JDK installé, quevousne pouvez pasen installer, ou que pour X raison vous devez vous contenter
d'un JRE, alors pour obtenir la Javadoc del'API standard de Java malgr € tout, vous avez les possibilités suivantes :
. En principe, dans les versions récentes d'Eclipse, vous ne paramétrez rien du tout, celui-ci sait d§a a quel URL
aller chercher la Javadoc del' API standard.
Pour Java 6, I'URL est http://java.sun.com/javase/6/docs/api/, comme le montre ceci.
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Dans ce cas précis, I'inconvénient est qu'il faut ére sir d'avoir un acces Internet actif, sans quoi, la Javadoc ne
sera évidemment pasdisponible.

. Vous pouvez aussi vous débrouiller derapatrier un fichier src.zip, en le plagant danslerépertoire devotre JRE.
Sur I'image ci-dessus, on peut d'ailleursvoir que cela a ééfait ainsi, puisque le Sour ce attachment pointe dessus.
De fait, dans ce cas de figure, le paramétrage de la Javadoc location devient inutile mais cela ne pose pas de
problemed'avoir lesdeux a priori.
En revanche, ce qu'il faut évidemment éviter, c'est de paramétrer une version de src.zip qui ne corresponde pas
avotrecasdefigure.
En principe, un JRE aura toujours la méme API d'une version majeur al'autre, donc I'URL de sa Javadoc ne
changera pas, méme suite au passage par exemple, d'un JDK/JRE 1.6.0_14 & 1.6.0_20. En revanche, cela sera
beaucoup moinsvrai pour les sources, donc lefichier src.zip doit vraiment étre en phase avec la version de Java
utilisée.
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L 'exemplepr écédent montrecomment configur er laJavadoc ou |'attachement dessour ces, en passant par lespropriétés
du projet Java. En réalité, le méme paramétrage est également possible via les préfér ences générales.
. Pour Configurer la Javadoc del'API standard de Java:

. Aller dansle menu Window > Preferences > Java > Installed JREs

. Dansle panneau de droite, sélectionner le JRE

. Cliquer sur le bouton Edit

. Renseigner I'URL (ou lerépertaire, ou I'archive)

. Pour Configurer la Javadoc d'unelibrairie utilisée dansun projet, par exemplelalibrairie Strutsdont lejar du
binaire est strutsjar.
. Aller dansle menu Project > Properties > Java Build Path > onglet Libraries
. Sélectionner lefichier strutsjar (ou lejar qui vousintéresse) puisouvrir I'arborescence de cettelibrairie
. Sélectionner I'éément Javadoc location
. Cliquer sur le bouton Edit
. Renseigner une URL similaire a ceci struts/docs/api/, qui est laracine de la Javadoc

La configuration dela Javadoc d'un librairie est possible en spécifiant une URL, un répertoire ou une ar chive.
Il est recommandé de rapatrier toutes les Javadocs distantes dans un répertoire local, afin d'avoir un accés rapide et
ne pas étre dépendant d'une connexion Internet.

Comment lier les sources au JDK ou aunelib ?

Auteurs: L'équipe Eclipse, Laurent.B ,

. Configurer lessourcesdel'API standard de Java :
. Aller dansle menu Window > Preferences > Java > I nstalled JREs
. Dansle panneau de droite, sélectionner le JRE
. Cliquer sur le bouton Edit
. Renseigner I'URL (ou lerépertaire, ou I'ar chive)

A noter qu'il faut cibler un JDK et non pasun JRE car seul leJDK possédele codesource. D'unemanieregénérale,
il est toujours préférablede cibler un JDK a cet endroit-1a car, en plusde vous per mettre de disposer des sour ces
et dela Javadoc, certains outils ne sont utilisables qu'avec un JDK.
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. Configurer le code source d''une librairie utilisée dans un projet, par exemple la librairie Struts dont lejar du
binaire est struts,jar.
. Aller dansle menu Project > Properties > Java Build Path > onglet Libraries
. Sélectionner lefichier strutsjar (ou lejar qui vousintéresse) puisouvrir I'arborescence de cettelibrairie
. Séectionner |'élément Sour ce attachment
. Cliquer sur le bouton Edit
. Renseigner une URL similaire a ceci struts/src/, qui est laracine du répertoire source

La configuration des sourcesd'unelibrairie est possible en spécifiant une URL, un répertoire ou une archive.

Il est recommandé de rapatrier tous les packages de sources distants dans un répertoire local, afin d'avoir un accés
rapide et ne pas étre dépendant d'une connexion I nternet.

A noter également qu'en rattachant le code source a unelibrairie, vous rendez implicitement disponible sa Javadoc.

L orsguevousvoulez consulter lessour cesd'uneclasse, par exemple String, appuyer sur SHIFT puisplacez votr e cur seur
au-dessus de la déclaration String. Ainsi, vous verrez apparaitre une fenétre présentant le code source de la classe
survolée.

Si vous souhaitez réellement " descendre" dans le code sour ce de classe, appuyez a la place sur CTRL puis clic gauche
sur la classe ciblée.

[2.X] Comment changer |e browser utilise pour afficher les pages d'aide ?

IAuteurs: bobuse,

Menu Window > Preferences, puisdans Help, sélectionner |'item Custom browser. Vous pouvez modifier lacommande
lancée

Par exemple sous KDE, mettre " kfmclient openURL % 1" . pour ouvir I'aide dans un nouvel onglet de Konqueror ou
"konqueror % 1" maisdans ce cas une nouvelle fenétre est ouverte a chaquefois

[3.x] Comment changer le browser utilise pour afficher les pages d'aide ?

Auteurs: djo.mos,

Menu Window > Preferences, puisdans General, sélectionner I'item " Web Browser".

Vous pouvez soit utiliser le navigateur interne d'Eclipse (en cochant " Use internal web Browser™), soit utiliser un
navigateur externeinstallé dansle systéme (en cochant " Use external Web browser").
Il faut ensuite choisir I'un des navigateursinstallés dansla liste ou en ajouter un vialesboutons" Add" ou " Search".

Comment générer la JavaDoc de votre projet ?

Auteurs: Lunatix , Laurent.B,

Bouton droit sur le projet, menu Export... > Java > Javadoc, indiquez la destination et cliquez sur Finish.

détails

. Lors dela premiére utilisation, vous devrez renseigner I'emplacement de I'utilitaire Javadoc, dans la premiéere
boite de dialogue.
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. Vousavez la possibilité de sélectionner spécifiquement les packages/classes/r épertoir es sour ce, pour lesquelsvous
souhaitez générer la Javadoc.

Comment exporter son application dans une archive JAR ?

Auteurs: Lunatix , djo.mos, Laurent.B,

Bouton droit sur le projet, menu Export... > Java > JAR File > Next.

détails

. Dans la 1ére page de I'assistant, vous devez spécifier le nom du fichier jar exporté, mais aussi sélectionner avec
précision les classes et ressourcesaincluredanslejar.

. Dansla 2éme page, il est possible (entre autres) d'ajouter une description du Jar génér é au wor kspace.

. Dansla 3émepage, il est possibled'indiquer a Eclipse, soit de générer automatiquement lefichier MANIFEST (et
éventuellement I'ajouter au workspace), soit d'utiliser un fichier MANIFEST existant (dans le wor kspace).
Dans cette méme page, il est possible de choisir la classe a exécuter automatiquement au lancement du jar.

Attention : Si vousavez ajoutédesjarsexternesau build path du projet, lejar nepourrapasfonctionner unefoisgénéré

car Eclipsen'inclut paslesinformationsdu build path.

Pour pallier acela:

. Fournir al'assistant d'export votre propre fichier manifest (généré par un premier export éventuellement) dans
lequel vousprécisez lesjarsquevousutilisezen ajoutant lalignesuivante: Cl ass- Pat h: | og4j .jar, nysql -
connector-java-5.1.6-bin.jar

Assur ez-vous également que cesjars soient présentsa cotédu jar généré, avant delelancer.

[3.4] Comment exporter son application dans une archive JAR exécutable ?

Auteurs: djo.mos, Laurent.B ,

Eclipse 3.4 (Ganymede) offre un nouvel assistant d'export de JAR exécutable, qui inclut toutes les dépendances du
projet (JARs externes) dans|'ar chive générée.

Avant de pouvoir utiliser cet assistant, il faut avoir exécuté le projet au moins unefois, c'est adire avoir au moinsune
configuration de lancement.

Ensuite, faitesun clic droit sur le projet, menu Export... > Java > Runnable JAR File > Next.

Dans la fenétre de I'assistant, vous devez sélectionner la configuration de lancement et spécifier le nom du fichier jar
exporté, puisvalider (bouton " Finish").

Unefenétres affichevousdemandant derevoir leslicensesdesbibliothequesqui seront décompressées et recompr essées
dansle JAR exporté, pour voir si elles permettent ce casd'utilisation.

[2.X] Comment passer des arguments ala JVM de mon application ?

Auteurs: L'équipe Eclipse,

Bouton droit sur la classe a exécuter dansle package explorer Run as > Run onglet (x)= Arguments
Dans Program arguments: lesargumentsde I'application (de la méthode main(String[] args))
DansVM arguments: les paramétres dela machinevirtuelle
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Auteurs: djo.mos,

Aprésavoir lancé I'application au moins une fois pour avoir une configuration de lancement, allez dans le menu Run
> Run Configurations et sélectionnez la configuration qui vous intéresse parmi la liste et activez I'onglet onglet (x)=
Arguments

Dans Program arguments: les argumentsde I'application (de la méthode main(String[] args))

DansVM arguments: les paramétres dela machinevirtuelle

Comment changer les répertoires source et de compilation ?

Auteurs: L'équipe Eclipse, Laurent.B ,

Pour modifier les répertoires source et de compilation :
. Faitesun clic droit sur le projet, menu Properties > Java Build Path, puis sélectionnez |'onglet Sour ce.

Ensuite, vous avez les choix suivants:

. Sélectionnez Add folder pour ajouter un répertoire sour ce supplémentaire.

. Sélectionnez Remove folder pour ne plus considérer un répertoire comme un r épertoir e source.
. Dans la zone Default output folder, vous pouvez changer le répertoire de compilation par défaut.

Auteurs: Lunatix , djo.mos, Laurent.B,

Parfois, on peut étre tenté de placer des fichiers de configuration, dans le répertoire de compilation
(application.properties, fichiers .xml, ...).

Cependant, par défaut Eclipsevide cerépertoirelorsd'une compilation compléte (lor squel'on sélectionne par exemple
le menu Project > Clean...).

Il est possible de paramétrer Eclipse pour qu'il ne fasse plus ce ménage, via le menu Window > Preferences > Java >
Compiler > Building > Output folder, en décochant Scrub output folder when cleaning projects.

Cependant, une solution bien plus propre et largement préférable est de créer un répertoire danslequel vous ne placez
gue vosfichiersde configuration.

Donc, tout smplement :

. Créez un répertoire nommé par exemple config au sein du projet.

. Faites ensuite un clic droit dessus, puis sélectionnez le menu Build Path > Use as Sour ce Folder.

Ainsi, lecontenu devotrer épertoir e seraautomatiquement prisen compteet recopiédanslerépertoire de compilation,
a coté de vosfichiers compilés.
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A noter que les fichiers du répertoire sont copiés dans le répertoire de compilation par défaut, qui est généralement
le répertoire /bin. Vous pouvez cependant changer de répertoire de destination, si cela vous est nécessaire, en le
paramétrant danslespropriétésdu projet (cf. Comment changer lesrépertoires source et de compilation ?).

Commen ser ou définir des templates de code ?

Auteurs: bobuse, Laurent.B

Lestemplates sont des bouts de code accessibles via desraccour cis typogr aphiques.
Par exemple, tapez sys quelque part dans votr e code sour ce d'une classe Java et appuyez sur CTRL + Espace.
Ceci provoque |'affichage d'une fenétre, comme indiqué sur I'image suivante ;

i

= Bparam args
v

public static void mainiStringl] args) {

syl
=| syserr - prink ko standard errar
=| sysaut - print o standard out
|=l swstrace - print current methad to standard out
@ system - java.lang
[C] SysexMessage - javax,sound midi
€9 SYSTEM_EXCEPTION - ora.oma Portablelnterceptar
@ systemolor - java. ant
G systemEsxception - org.cma, CORBA

[systen err_princlni);

|»

@ systemFlavorMap - java, awt, datatransfer

[c] SystemMenuBar - javax.swing plaf, basic,BasicInternalFr

@ systemTray - java. awt -

< | »
Press ‘Ctrl+Space’ to show Template Proposals Press 'Tab' from proposal table or click for Focus)

Sélectionnez sysout - print to standard out et appuyez sur Entrée.
Et voila! Le code System.out.printin(); a é&éinséré.

Parmi les templates prédéfinis, ceux-ci vous permettent de générer des squelettes de code qui vous aiderons a
programmer plusrapidement.
Autresexemples:
. Créer uneinstanced'une classe:
. Tapez new puis CTRL + Espace
. Sélectionnez le template new - create new Object et le code type name = new type(ar guments); est généré,
avec les champs a compléter encadrés, et le premier mot type sélectionné.
. Sans déplacer le curseur, saisissez Integer en lieu et place du mot type et vous constaterez que le troisiéme
champ (I'appéel du constructeur) se modifie smultanément !
. Appuyez sur Tab pour passer au champ suivant (lenom delavariable) et donnez le nom que vous souhaitez
avotrevariable (par exemple: monlnteger).
. Appuyer de nouveau sur Tab et vous passez a I'argument du constructeur de Integer, dans lequel vous
pouvez initialiser votrevariable (par exemple: 10).
. Pour finir, appuyer sur Entrée et votre votre variable est initialisée et les cadres entourant les ééments a
adapter disparaissent.
. Générer rapidement une boucle d'itération :
. Tappez for puis CTRL + Espace et complétez les é éments encadr és

Vous pouvez également définir vos proprestemplates :

Pour cela, allez dansle menu Window > Preferences > Java > Editor > Templates.

Pour des besoins spécifiques, analysez ceux qui sont déja présents pour comprendre comment produirelesvotres.
L'outillage fourni est relativement puissant maisil faut apprendre a le maitriser avant de savoir si vous pourrez créer
lestemplates souhaités.

Voici un exemple de création de template manquant, qui permet de formater plus proprement un texte de Javadoc, en
ajoutant lesbalisssHTML <p></p> autour d'un paragraphe:

. Cliquez sur le bouton New... et remplissez les valeurs qui suivent

. Name: <p>

. Context : Javadoc

. Description : <p></p>
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. Pattern :
<p>${wor d_sel ecti on}${} </ p>${cursor}

A noter que ce template est basé sur celui du <b></b> qui met en gras une zone de texte Javadoc. M alheur eusement,
(sauf erreur et évolutions ultérieures) les limitations de I'outil imposent que I'on ne puisse appliquer ce template que
sur un texte de Javadoc d'une seule ligne. Donc, cela nécessite de manipuler manuellement le paragraphe pour queles
balises début et fin, soient placées aux bons endr aits...

Un autre exemple treés utile lorsgue vous utilisez I'api commons-logging, de maniére & générer proprement et
dynamiquement la déclaration du logger :

. Cliquez sur le bouton New... et remplissez les valeurs qui suivent

. Name: Ig

. Context : Java

. Description : Instanciation del'objet delog

. Pattern :

/** Traces */
private static final Log | og = LogFactory. getLog(${encl osing_type}.class);

A utiliser en début decorpsd'uneclasse. Trésefficace contrelesmauvaiscopier/coller qui gardent malencontreusement,
et &fort mauvais escient, le nom dela classe d'origine...

Remarque : Les templates sont importables et exportables, ce qui est notamment pratique pour homogénéiser le
développement d'applications en équipe.

IIs ne sont pasréservés au langage Java (et autreslangages liés) mais pour pouvair lesutiliser dans d'autres langages/
technos, il faut qu'un menu dédié soit disponible dans les préférences.

C'est I'gjout de plug-ins embar quant ce genre de fonctionnalité qui peut permettre d'en disposer.

| Comment utiliser JUnit avec Eclipse ? |

Auteurs: L'équipe Eclipse,

Leframework detest Junit est trés utilisé et est disponible sur ﬁwww.junit.org

Il est completement intégré a Eclipse, et vous n'avez besoin derien installer.

Dans le package explorer bouton droit sur une classe a tester > New Junit test case et vous aurrez un assistant déja

renseigné.

L es petitsplus

. L a deuxieme page de |'assistance per met de sélectionner les methodes et constructeurs a tester

. Je vous conseille de placer les classes Junit dans le meme package que la classe a tester (fait par defaut), mais
dansun répertoire de sources different

. Si vous codez d'abord la classe de test (facon xp programming), faitesfile > new > junit test case

Pour exécuter le ou lestests, bouton droit sur la classe ou le package, Run as > JUnit test

Comment debugger une application Java ?

Auteurs: Lunatix , Laurent.B,

Dans la mar ge gauche d'une classe, vous pouvez ajouter (ou retirer) un point d'arrét, en double cliquant sur laligne
souhaitée. A noter que vous obtiendrez le méme résultat en passant par un clic droit > Toggle breakpoint.
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Cepoint d'arrét entre en action lorsque vous exécutez votre programme en mode Debug et quelaligne ou il setrouve

doit étre exécutée.

Eclipse géle alors I'exécution du programme et attend une action de I'utilisateur pour savoir comment le débuggage

doit continuer.

Vous pouvez mettre des breakpoints partout ou cela vous semble nécessair e mais uniquement a des endroits cohérents.

Lesactions possibles du mode Débug :

Les petitsplus

. Danslaview Debug : Step into (F5) permet derentrer dans une méthode

. Danslaview Debug : Step over (F6) permet de poursuivrel'exécution en mode pas a pas.

. Danslaview Debug : Step return (F7) permet de poursuivre|'exécution jusqu'a sortir dela méthode courante.

. Danslaview Debug : Resume (F8) permet dereprendrel'exécution normalement ou Sarréter uniquement si un
autre point d'arrét est rencontré.

. Danslaview Variables: Vous pouvez consulter lesvaleursdesvariables

. Danslaview Variables: Unevariable en rouge est une variable qui vient d'ére modifiée

. Danslaview Variables: Bouton droit sur unevariable : Edit value permet de changer a chaud la valeur

. Danslaview Breakpoints: Vous pouvez activer/désactiver desbreakpointssanslesretirer

. Danslaview Breakpoints: Lebouton j! permet de mettreun breakpoint sur toutesles Exceptionsdu programme

. Dans la view Breakpoints : a |I'aide de la fléche noire orientée vers le bas, activez Show working Sets. Puis dans
le méme menu, sélectionnez Working Sets, Exception et donnez un nom. Voila, vous avez maintenant un groupe
d' Exceptions sous ce nom, que vous pouvez activer d'un simpleclic de souris.

Remarque : Si jamais vous constatez qu'un point d'arrét, lorsque vous tentez de le placer sur une ligne de code, se
retrouve décalé, alorscelasignifietrés probablement quelerépertoire de compilation configurédansvotre projet, n'est
pasajour par rapport au code source affiché. Cela est souvent le cas lorsque par exemple vous compilez avec Ant et
gue lesrépertoires des classes compilées ne sont pasidentiques a ceux paramétrés dansvotre projet Eclipse.

Deméme, si en cours de débug, vous constatez que le mode pas a pas n'est pas synchronisé avec le code sour ce affiché,
c'est sansdoute pour les mémesraisons.

Si vous ne compilez pas avec Ant ou un autre outil de build, vérifier queI'option Build Automatically est cochée dans
le menu Project.
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Sommaire > Dével oppement J2EE

[2.X] Comment développer en JEE avec Eclip:

Auteurs: L'équipe Eclipse,

Cetteversion d'Eclipse n'intégre pas par défaut les outils nécessaires au développement J2EE. || faut doncinstaller un
ou plusieurs plug-ins supplémentaires.

Par exemple:

Plugins J2ee

Plug-in Tomcat “Www.eclipsetotale.com/tomcatPIugin.html

Eclipse Web tools ﬁ www.eclipse.or g/webtools/
. et d'autres...

| [3.X] Comment développer en JEE avec Eclipse ? |

Auteurs: djo.mos,
Il est possible de développer en JEE avec Eclipseg, en partant par exemple du package" Eclipsefor JavaEE Developers'

ou alors, en installant HWebTools.

Ainsi, on ala possibilité d'utiliser les outils suivants:

. Assistants pour la génération d'applications Web (WAR) ou EAR.

. Assistants pour la création de Servlets, Filters, EJBSs, etc.

. Editeur defichiersHTML, JSP, CSS et JS.

. Support natif des serveursles plus populaires (Tomcat, JBoss, WebSphere, JOnAs, OC4J, etc.)
. Support de JSF

. Support de JPA

. etc.

[2.X] Que sont lesWeb Tools ?

Auteurs: Lunatix , Laurent.B,

Il sagit des outils standar ds de développement JEE pour Eclipse.
LesitedesWeb Tools est “ Projet Eclipse Web Tools (WTP)

[2.x] Comment installer les Web Tools ?

Auteurs: L'équipe Eclipse,

Leplug-in Web Tools (WTP) est le plug-in officiel pour le développement JEE. Vous pouvez I'installer tréssimplement
via |'Update M anager.

Menu Help > Software updates > find and Install > Search for new features to install > deployez Eclipse.org update
site > sélectionnez WTP , GEF, JEM et EMF.

Il nevousreste plus qu'a accepter leslicenses et valider I'installation.

Attention, touslesmirroirsne disposent pasdesWTP.
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Plus de détails sur la procédure sur le site d'EcIipseﬁ update Site.

| [3.3, 3.2] Comment installer Eclipse WebTools ? |

Auteurs: djo.mos,

Le plug-in Web Tools Project (WTP) est e plug-in officiel pour le développement JEE. Vous pouvez l'installer trés
simplement a l'aide du gestionnaire de misesajour (s besoin consultez la fi [3.3-] Comment installer un plug-in ?).

Assurez-vous d'abord quel'update-site de WTP est bien dansla liste des sitesinclus dans la recher che.
Sil n'est pas présent, cliquez sur le bouton Add Remote Site, puis donnez un nom et renseignez I'URL http://
download.eclipse.or g/webtoolsupdates/

L'installation sefait al'aide du menu Help > Software updates > Find and I nstall > Search for new featuresto install,
déployez Eclipse.org update site, sélectionnez WTP et ses dépendances.
Il nevousreste plus qu'a accepter leslicenses et valider I'installation.

Uneautre solution consiste a téléchar gez le package Eclipse | DE for Java EE Developers, qui integre directement WTP

et qui est disponiblesur la pageﬁ http://www.eclipse.or g/downloads/mor einfo/jee.php.

[3.4] Comment installer Eclipse WebTools ?
IAuteurs: djo.mos,

Le plug-in Web Tools Project (WTP) est |le plug-in officiel pour le développement JEE. Vous pouvez l'installer trés
simplement al'aide du gestionnaire de misesa jour (si besoin consultez la fAl [3.4] Comment installer un plug-in ?).

Assurez-vous d'abord quel'update-site de WTP est bien danslaliste des sitesinclus dansla recherche.
Sl n'est pas présent, cliquez sur le bouton Add Remote Site, puis renseignez I'URL http://download.eclipse.or g/
webtools/updates/

L'installation sefait al'aidedu menu Help > Softwar e updates > Available Softwar e > Sear ch for new featurestoinstall,
déployez Webtools (WTP) Update Site, sélectionnez WTP et ses dépendances.
Il nevousreste plus qu'a accepter leslicenses et valider I'installation.

Uneautresolution consiste a téléchargez le package Eclipse | DE for Java EE Developers, qui integredirectement WTP

et qui est disponiblesur la pageﬁ http://www.eclipse.or g/downloads/pack ages/'r el ease/ganymede/sr 2.

[3.5] Comment installer Eclipse WebTools ?

Auteurs: djo.mos,

Le plug-in Web Tools Project (WTP) est le plug-in officiel pour le développement JEE. Vous pouvez I'installer tres
simplement al'aide du gestionnaire de misesa jour (si besoin consultez la FAl [3.5] Comment installer un plug-in ?).

Assurez-vous d'abord quel'update-site de WTP est bien danslaliste des sitesinclus dansla recherche.
Sil n'est pas présent, cliquez sur le bouton Add Remote Site, puis renseignez I'URL http://download.eclipse.or g/
webtools/updates/
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L'installation se fait a I'aide du menu Help > Install New Software..., sélectionnez The Eclipse Web Tools Platform
(WTP) Project update site - http://download.eclipse.or g/webtoolsupdates, puis cochez les composants WTP qui vous
intéressent, en particulier le bloc Web Tools Platform (WTP) 3.1.0.

Il nevousreste plus qu'a accepter leslicenses et valider I'installation.

Uneautresolution consiste a téléchar gez le package Eclipse | DE for Java EE Developers, qui integredirectement WTP

et qui est disponible sur la page“ http://www.eclipse.or g/downloads/.

[3.2+] Comment gjouter un serveur a Eclipse ?

Auteurs: djo.mos,

Eclipse WebTools offre un support pour une multitide de serveurs d'applications Java, qui permet entre autres de
deployer directement une application sur le serveur depuis Eclipse.

Pour ajouter un nouveau serveur a Eclipse, Allez dans:

. Eclipse 3.3 ou antérieur : Menu Window > Preferences > Server > Runtime Environments
. Eclipse 3.4 : Menu Window > Preferences > Server > Installed Runtimes

= Preferences (@[]
type filter text Server Runtime Environments P -
Run/Debug 1>/ Add, remove, or edit server runtime environments.
Scala - ]
Server runtime environments:
Server
Audi Name Type Add...
uaio 3 —_—
. ® Apache Tomcatv6.0.16 Apache Tomcat v6.0 [ Edit. . |
Launching — eI —
ringSource AP vl S PrS—
Runtime Environments L [ Remove |
Service Policies = [ search.. |
Spring | =Sudrtn..
Spring Beans XML Temnp
Tasks
Team
Usage Data Collector
validation
Web
Web Services
*Doclet
XML [+]
E:DH fhome/djofjavalservers/apache-tomcat-6.0.16
@ [ oK | cancel |

La page de configuration des serveurs

Cliquez sur le bouton " Add" . Dans la fenétre qui s affiche, séléctionnez le type de serveur et cochez la case " Create a
new local server". Cliquez ensuite sur " Next" .
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New Server Runtime Environment

New Server Runtime Environment
Define a new server runtime environment

Download additional server adapters

Select the type of runtime environment:
[ rpe filter tex] ]
- [ Apache

& Apache Tomcat v3.2
& Apache Tomcat v4.0
& Apache Tomcat v4.1
~

E Apache Tomcat v5.0
& Apache Tomcat vs.5

E Apache Tomcat v6.0
b = Basic
Apache Tomcat v6.0 supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules.

Create a new local server

@ | | Next> | Finish | cCancel |

La page de configuration du type d'un nouveau serveur

Remplissez les differents champs de la fenétre (principalement le nom du serveur et son emplacement sur le disque)
et validez.

New Server Runtime Environment

Tomcat Server
Specify the installation directory
Name:

[Apache Tomcat v6.0 ]

Tomcat installation directory:

[J’home!djo!ja\.ra!ser\.rers!apache-tomcat-s.0.18 ]
apache-tomcat-6.0.14 |Download and Install...

|RE:
[Workbench default JRE o] ] [ Installed JREs... ]
@ [ < Back ] Next = | I Finish [ Cancel ]

La page de configuration d'un nouveau serveur

Leserveur est désormais configuréet prét a étre utilisé.
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Veuillez noter que la configuration relative a ce serveur est stocké dans un nouveau projet crée automatiquement par
Eclipse et nommé" Servers'. Pour pouvoir utiliser le serveur, il est impératif que ce projet soit ouvert.

[3.2+] Comment créer un projet web Java ?

Auteurs: djo.mos,

Pour créer un nouveau projet web Java dans Eclipse, Allez dans Menu File > New > Other > Web > Dynamic Web
Project

Danslafenétre qui s affiche, saisissez un nom pour le projet a créer et cliquez sur " Next"

= New Dynamic Web Project
Dynamic Web Project 5

Create a standalone Dynamic Web project or add it to a new | @
or existing Enterprise Application.

Project name: [nom-du—projet ]

Project contents:
Use default

Target Runtime

|Apache Tomcat v6.0 S| New...|

Configurations

|Default Configuration for Apache Tomcat v6.0 2

A good starting point for working with Apache Tomcat w6.0 runtime.
Additional facets can later be installed to add new functionalitv to the

@ | < Back | Next = | i Fnish | Cancel |

Assistant de création d'un projet web Java

L es pages suivantes permettent de configurer en détail les paramétres du projet. Vous pouvez les laisser tel quels et
utiliser lesréglages par défaut.

[3.2+] Comment deployer et exécuter une application web sur un serveur ?

Auteurs: djo.mos,

Pour deployer de exécuter un projet web Java dans un serveur depuis Eclipse, Sélectionnez le projet dans la vue
" Package Explorer" ou " Project Explorer”, puiscliquez sur la petite fléche orienté versle bas du bouton Run (Cercle
vert avec un traingleblanc al'intérieur" dansletoolbar.

Séectionnez Run As> Run on Server
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L= Java EE - Ecl

le Edit MNavigate Search Project Run Window Help
il 130 Q- |G-6 | ®esy/ 02|
|.—[\:| Project Explumi Aoiaunch ity

I

AL

b = Servers
S web-project
4 ‘Deployment Descriptor: web-proje

Run Configurations... | & 2 Java Applet Shift-+AI+X A
Organize Favorites... 3 Java Application  Shift+Alt+X |

4 %Ja\ra Resources: src
b =build

b =web

v e JavaScript Support

Assistant d'exécution d'un projet dans un serveur

Danslafenétre qui saffiche, sélectionnez un serveur déa configuréet cliquez sur " Finish"

|' = Aun On Server &) 23

Run On Server
Select which server to use

How do you want to select the server?

(@ Choose an existing server

(*) Manually define a new server

Select the server that you want to use:

[type filter text

= = localhost

R Tomcat v6.0 Server at localhost - Stopped

Apache Tomcat v6.0 supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web
modules.

|:| Always use this server when running this project

@ < Bac Next > Finish Cancel

Assistant d'exécution d'un projet dans un serveur

Veuillez noter qu'il est possible de créer un nouveau serveur directement depuis|'assistant d'exécution.
Pour cefaire, il faut sélectionner I'option " Manually define a new Server" et suivrel'assistant.

Unefoisl'assistant terminé, I'application sera deployée sur le serveur et cedernier démarré.
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Sommaire > Développement J2ME

Auteurs: Lunatix ,

Utilisez le plug-in EclipseMe: -eclipseme.org
Suivez bien lesinstructions d'installation sur lesite.
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Sommaire > La Plate-Forme Eclipse

IAuteurs: Laurent.B ,

Traduction de la définition suivanteﬁ http: //www.eclipse.or g/platform/overview.php

La Plate-Forme Eclipse fournit les frameworks et services de base a partir desquelstousles plug-ins d'extensions sont
créés. Elle fournit également I'environnement d'exécution danslequel les plug-ins sont char gés, intégr és et exécutés.

L'objectif principal de la plate-forme est de permettre aux développeurs d'outils tiers de facilement développer et
proposer desoutilsintégrés.

La plate-forme en elleméme est une sorte de plate-forme d'outils universelle. C'est un EDI de tout et de rien en
particulier. Elle peut manipuler n'importe quel type deressource (fichiersJava, C, Word, HTML, JSP, etc) de maniére
générique, sans pour autant savoir comment lestraiter spécifiquement. La plate-forme Eclipse en ellemémen'est pas
pourvued'énormément defonctionnalitésutilisateur, c'est quelque part ce qui fait sont intérét. Savéritablevaleur vient
des plug-ins qu'on lui ajoute afin de lui apprendre a travailler avec différents types de ressources. Cette architecture
par plug-in per met une expérience plustransparente pour I'utilisateur final, lorsgqu'il navigue entrelesdifférentsoutils,
comme celan'ajamais été possible auparavant.

La plate-forme Eclipse définit un ensemble de frameworks et de services communs qui forment collectivement une
application d'intégration, nécessair e au support d'une plate-forme compléte d'intégration. Ces services et frameworks
représentent lesfonctionnalitéscommunesrequisespar laplupart desoutilsde construction, incluant un environnement
utilisateur standard, un modéle de projet pour la gestion de ressources, des widgets nativement portables, des
bibliotheques d'interface utilisateur, une gestion des modifications de ressources de maniére automatique pour les
compilateurs et constructeurs, une infrastructure de débuggage indépendante du langage, ainsi qu'une infrastructure
pour la gestion des ressour ces ver sionnées en environnement distribué multi-utilisateur.

De plus, la plate-forme Eclipse définit un environnement utilisateur et un ensemble de paradigmes d'interactions
utilisateur spécifiques a chague domaine, auquel les outils de construction se connectent pour ajouter de nouvelles
capacités. La plate-forme vient avec un ensemble de vues standards qui peuvent étre étendues par les outils de
construction. Ces derniers peuvent a la fois gjouter de nouvelles vues ainsi que connecter, aux vues existantes, de
nouvelles capacités spécifiques a un domaine.

Auteurs: Gueritarish ,

Pour pouvoir examiner une classe de la plateforme Eclipse correspondant a un éément affiché directement a I'écran,

il faut passer par le plug-in Spy. Cette fonction est accessible a partir de 2 raccourcis clavier :

. ALT + SHIFt + F1 (Plug-in Selection Spy) permet d'afficher les informations sur la sélection courante
(typiquement, lecomposant ayant lefocus: wizard, éditeur, vue..). Cesinfor mationsdonnent leplug-in contribuant
a ce composant, I'identifiant de la (des) section(s) d'aide, les classes implémentant ce composant...
Exemple pour |'éditeur Java:
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% Plug-in Selection Spy X

Active Shell

The active shell class:
© WorkbenchWindow

Active Part (Java Editor)
The active editor class:
@ CompilationUnitEditor
The contributing plug-in:
= org.eclipsejdt.ui (3.6.2.r362 v20110203
The active editor identifier:
org.eclipse,jdt.ui.CompilationUnitEditor
The active menu contribution identifiers:
org.eclipse,jdt.ui.CompilationUnitEditor.EditorContext
#AbstractTextEditorContext
#CompilationUnitEditorContext
#AbstractTextEditorRulerContext
#CompilationUnitRulerContext
org.eclipse.jdt.ui.CompilationUnitEditor.RulerContext

#0verviewRulerContext

Active Selection

The selection class:
® TexdSelection

The interfaces valid for the selection:
© ITextSelection

. ALT + SHIFT + F2 (Plug-in Menu Spy) permet d'afficher les informations sur la sélection de I'utilisateur. On
peut donc chercher desinformations sur les commandes dans les menus (contextuels ou non), lestoolbars... Les
infor mations contiennent en plus|'emplacement de la commande (entre autre).

Exemple pour la commande Save As:

4 Plug-in Menu Spy %

Active Selection

The active contribution item identifier:
savels

The active contribution location URL
menu:filelafter=savehs

The active action definition identifier:
org.eclipse.uifilesavehs

The active contribution item class:
® savefisAction

The contributing plug-in:
<= org.eclipse.ui.workbench (3.6.2,M20110210-1200

Il est anoter quele Plug-in Menu Spy n'est apparu qu'a partir delaversion 3.5 d'Eclipse.
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Sommaire > La Plate-Forme Eclipse > Dével oppement RCP

Comment développer une application RCP ~

IAuteurs: Laurent.B ,
Pour développer une application RCP, la premiére chose a faire est de partir du bundle Eclipse for RCP and RAP

Developers, disponibleici ‘ http://www.eclipse.or g/downloads/.

Ensuite, vous pouvez suivre les tutoriels présents ici ﬂhttp://eclipse.developpez.com/cours/?page:platform—

cat#plugin-dev ou ici ‘ http://www.eclipse.or g/r esour ces.

Lorsquel'on développe uneapplication RCP, un desprincipaux objectifsest deréutiliser cequi est déjadisponible, afin
bien entendu de nepasréinventer laroue. Tout ceci nécessite de prendreletempsd'étudier un minimum I'ar chitecture
delaplate-formeet ensuited'identifier lesélémentsdebase nécessair esau développement del'application en particulier.
Une application RCP étant constituée de plug-ins, il est donc important de savoir comment les architecturer, les
implémenter, ainsi que de comprendreleur cycle devie et leurs dépendances avec lereste de|'application.

Afin defaciliter votre prise en main dela plate-forme Eclipse, n'hésitez pas a vous procurer deslivres.
Voici quelques-uns des ouvrages disponibles:

' ﬂ Eclipse: Principes, patternset plugins(21 juillet 2004)

‘ Eclipse Rich Client Platform (2nd Edition)(22 mai 2010)

B Eclipse Plug-ins (3rd Edition)(21 décembre 2008)

‘ EMF: Eclipse Modeling Framework (2nd Edition)(26 décembr e 2008)
‘OSGi and Equinox: Creating Highly Modular Java Systems(24 février 2010)

lien : FAG Définition de SWT et de JFace

Auteurs: Gueritarish,

Pour créer un projet programmatiquement, il faut tout d'abord ajouter une dépendance vers le plug-in
org.eclipse.core.resour ces et ensuite instancier un | Project:

String nane = "MonProjet";

| Wor kspace wor kspace = ResourcesPl ugi n. get Wr kspace();
| Wor kspaceRoot root = workspace. get Root ();

| Proj ect project = root.getProject(nane);

proj ect.create(new Nul | Progresshnitor());

proj ect. open(new Nul | Progresshnitor());

Il faut ensuiteajouter lanaturedu projet (Java, C++, Android, ...). Généralement, desconstantessont prévuesacet effet.

| Proj ect Description desc = project.getDescription();
desc. set Naturelds(new String[] { "MyNaturel D" });
proj ect. set Descri ption(desc);

On peut ensuite définir le classpath et le dossier de sortie de compilation...
Par exemple, pour un projet Java (avec la dépendance ver s or g.eclipse.jdt.cor e):

/'l Dossier de sortie vers "bin":
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| JavaProj ect javaProj = JavaCore.create(project);
| Fol der binDir = project.getFolder("bin");

I Path binPath = binDir.getFullPath();

j avaProj . set Qut put Locati on(bi nPath, null);

String path = "c:\\jre\\lib\\rt.jar";
| G asspat hEntry cpe= JavaCore. newLi braryEntry(path, null, null);
j avaProj . set RawCl asspat h(new | O asspat hEntry[] {cpe});
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Sommaire > La Plate-Forme Eclipse > Développement de Plug-ins

Comment développer un plug-in Eclipse ?

Pour développer un plug-in Eclipse, la premiére chose a faire est de partir du bundle Eclipse for RCP and RAP
Developers, disponibleici - http://www.eclipse.or g/downloads/.

Ensuite, vous pouvez suivre les tutoriels présents ici “http://eclipse.developpez.com/cours/'?page:platform-
cat#plugin-dev ou ici - http://www.eclipse.or g/r esour ces.

Afin defaciliter votre prise de connaissances sur le développement de plug-ins, n'hésitez pasavousprocurer deslivres.
Voici quelques-uns des ouvrages disponibles:

BA Eciipse: Principes, patterns et plugins(21 juillet 2004)
BB Eclipse Plug-ins (3rd Edition)(21 décembre 2008)

lien : FAQ Définition de SWT et de JFace

Comment activer, désactiver, rendre visible ou invisible un menu en fonction d'une variable ?

Tout d'abord, pour créer un menu que I'on peut activer ou désactiver en fonction du contexte, voici comment il faut
procéder :
Déclarer un Sour ceProvider danslefichier plugin.xml del'application :

<ext ensi on point="org. eclipse.ui.services">
<sour ceProvi der provider="com foo. nyapp. MySour cePr ovi der " >
<variabl e
name="com f 0o. nyapp. nyVari abl e"
priorityLevel ="wor kbench">
</vari abl e>
</ sour ceProvi der >
</ ext ensi on>

Ou:

. com.foo.myapp.MySourceProvider est la classe qui va étendre | Sour ceProvider
. com.foo.myapp.myVariable est le nom delavariable

Ensuite, créer la classe MySourceProvider dans le package com.foo.myapp. Cette classe hérite de
AbstractSourceProvider (pour plusdelisibilité).
public class MySourceProvi der extends Abstract SourceProvider {

/** Nomde |la variable a vérifier. */
public final static String VAR ABLE = "com foo. nyapp. nyVari abl e";

/** Val eur de |'état actif. */
private final static String ENABLED = "enabl ed";

/** Val eur de |'état inactif. */
private final static String D SABLED = "di sabl ed";

/** L'état courant de |la variable. */
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private bool ean enabl ed;

@verride
public String[] getProvidedSourceNanes() {

return new String[] {VAR ABLE};
}

@verride
public Map getCurrentState() {

String variabletState = enabl ed ? ENABLED : Dl SABLED;

Map current State = new HashMap(1);
current St at e. put (VARI ABLE, variabl eState);

return currentState;

}
/

*

t & jour |'état de la variable.

Me

@aram flag Flag fournissant |'état de la variable :
<code>t rue</ code> pour {@ink MySourceProvi der #ENABLED ENABLED} ,
<code>f al se</ code> pour {@ink MySourceProvider#Dl SABLED DI SABLED} .

¥k ok ok ok Ok F

/
public void setVariabl eState(bool ean flag) {

if(this.enabled == flag) {
return;

}

this.enabled = flag;
String currentState = enabl ed ? ENABLED : DI SABLED;
fireSourceChanged(| Sour ces. WORKBENCH, VARI ABLE, current State);

Danslefichier plugin.xml, ala définition du handler dela commande, rajouter :

<ext ensi on
poi nt ="org. ecl i pse. ui . handl ers">
<handl er
cl ass="com f oo. MyHandl er"
conmmand| d="com f 0o. nyConmand" >
<activeWhen>
<with
vari abl e="com f oo. nyapp. nyVari abl e" >
<equal s
val ue="enabl ed" >
</ equal s>
</wth>
</ acti veWhen>
</ handl er >
</ ext ensi on>

Ensuite, appeler la méthode setVariableState() pour mettre ajour la valeur dela variable (enabled ou non). Ex. dans
un listener :

bool ean newvari abl eState = true;

| Sour cePr ovi der Servi ce sourceProvi der Servi ce = (| SourceProvi der Servi ce)
Pl at f or mJl . get Wor kbench() . get Ser vi ce(| Sour ceProvi der Servi ce. cl ass);

if (sourceProviderService !'= null) {
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| Sour cePr ovi der provider = sourceProvider Service. get Sour ceProvi der (MySour ceProvi der. VARl ABLE) ;
if (provider instanceof MSourceProvider) {

((MySour ceProvi der) provider).setVariabl eState(newvari abl eState);

Pour ce qui est derendrevisible ou invisible le menu, on peut utiliser le méme principe, c'est-a-dire en déclarant ceci :

<ext ensi on
poi nt="org. ecl i pse. ui . nrenus" >
<menuContri bution

I ocati onURl =" nenu: com f 0o. ny. nenu?aft er =addi ti ons" >

<command
command| d="com f 0o. nyConmand" >
<vi si bl eWhen
checkEnabl ed="f al se">

<with
vari abl e="com f oo. nyapp. nyVari abl e" >
<equal s
val ue="enabl ed" >
</ equal s>
</wth>

</ vi si bl eWhen>
</ command>
</ menuCont ri buti on>
</ ext ensi on>
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Sommaire > La Plate-Forme Eclipse > SWT / JFACE

Auteurs: Lunatix , djo.mos,

SWT est une bibliothéque qui sert a construire des interfaces graphiques en Java, au mémetitre que les bibliothéques
AWT et Swing.

Laparticularitéde SWT est dedéléguer |'affichage graphique au systémed'exploitation. Concrétement, atraversSWT
vous utilisez lesMFC, Gtk ou autres.

JFace est une surcouche de SWT, davantage orientée objet, qui améne de plus un modéle MV C et des fonctionnalités
supplémentaires.

Quelles sont les différences entre SWT et Swing ?

Auteurs: Lunatix ,

Swing est une API "lightweight", c'est-a-dire qu'elle redessine tous les composants graphiques (widgets) a I'aide des
primitives de Java2D.

SWT quant a lui, utilise les APl graphiques du systéme d'exploitation, c'est-a-dire que ses widgets sont dessinés
directement par cedernier.

En d'autres termes, pour afficher un bouton, Swing va dessiner un rectangle et placer un label au millieu, alors que
SWT va simplement demander au systéme d'exploitation de se charger de cette opération.

Sous SWT, chaque objet Java représentant un éément graphique, n'est qu'un wrapper vers du code natif.

Quels sont les avantages et inconvenients de SWT par rapport a Swing ?
Auteurs: Lunatix ,

Ici I'idée est de simplement présenter quelques pistes dereflexion, afin devous aider afaire votre choix.

Prenez tout de méme le temps d'approfondir le sujet, en vérifiant par exemple si ce qui est dit ici reste valable dans

letemps.

Avantagesde SWT

Avantages

. Non standard : vous pouvez distribuer vous méme SWT avec votre application ce qui permet de gérer finement
le versioning, de bénéficier rapidement des BugFixs et desmisesa jour

. Natif : SWT sadapte automatiquement au L ook and Feel du systéme d'exploitation. Une application Java sous
SWT va sadapter automatiquement a un windows customisé a |'extréme, ou a un Gtk avec un théme exctique

. Petite APl : SWT est une petite API, avec un nombre limité de widgets, et peu d'héritage, ce qui en fait une API
facileaprendreen main

. Consomation mémoaire: la consomation mémoirede SWT est plusfaible que celle de Swing

. Vous pouvez bénéficier du projet Eclipse RCP comme framework de développement

. Open Source

. Linkable : si vous prévoyez de compiler votre application avec GCJ et Gnu-Classpath, il est possible d'utiliser
SWT facilement (il existe uneversion de Eclipse native)

. Bonneintégration : possibilité d'utiliser COM, des plug-ins, le browser web natif pour rendredu HTML

Inconvénientsde SWT

Inconvénients

. Non standard : vousdevez distribuer vousméme SWT avec votreapplication, ce qui vaalourdir votredistribution
et parfoiscompliquer le déploiement

. Non standard : moins de compétences sur SWT, moins de doc, moinsd'aide sur leforum de DVP
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. Natif : on subit leslimitations de la plate-for me sous-j acente (taille maximum d'un champ texte, nombred'image,
pas de centrage des champs header, destables, ...)

. Gestion mémoire: il est nécessairedefaireun .dispose() sur tousles éémentsgraphiquespour liberer lamémoire
du composant natif qu'il représente

. Petite API : SWT/Jface est une petite API, et il manque des choses compar é a Swing

Portabilité: Comparée a Swing et ala version Windows, la version Gtk de SWT reste lente (ﬁ plusd'info)

. Pas d'applet possible

. Pas de SandBox possible dans Java Web Start, a cause des accés natifs

Quels sont les Widgets SWT ?

Auteurs: Lunatix ,

Vous pouvez voir leswidgets SWT sur cette page: =] Widgets SWT.
Chaque widget est présenté avec un exemple et sa Javadoc.

Ou trouver des exemples sur SWT ?

Auteurs: Lunatix ,

L 'équipe de développpement de SWT tient ajour une page d'exempl%ﬁ SWT Snippets.
Vous pourrez y trouver de nombreux exemples d'utilisation de chacun des widgets SWT, ainsi que la réponse a des

guestions plus complexes, comme comment lancer unetéchelongue dansun “Thread, gérer Ie“ Dragand Drop, ..

[3.0-] Comment lancer une application SWT ?

Auteurs: Lunatix ,

Pour lancer une application SWT, vous devez bien siir avoir lesjar SWT dans le classpath, mais aussi déclarer les

librairies natives. Celles-ci setrouvent dansle sous-répertoire de plug-ins org.eclipse.swt.[OS]

lancer swt

. Sous Eclipse 3.1M5+ : menu Run > Application SWT

. Sous Eclipse : menu Run > Run Java Applicaton > New > Arguments > VM Arguments et ajouter -
Djava.library.path=c:\eclipse\plugins\or g.eclipse.swt.win32_2.1.0\os\win32\x86

. Enfin, pour le distribuer vous devez aouter dans la ligne de commande @ -
Djava.library.path=chemin_vers librairies

Bien slr, vous devrez adapter ceslignesde commandes avotre OS et alaversion de SWT utilisée.

[3.2+] Comment lancer une application SWT ?

Auteurs: djo.mos,

Dans les versions récentes d'Eclipse, pour lancer une application SWT, il suffit juste d'ajouter le jar de SWT
correspondant a votre architecture (or g.eclipse.swt.gtk.linux.x86_3.4.0.xxx.jar par exemple pour Linux/x86)
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Cejar peut érerécupérédu dossier plug-insdevotreinstallation Eclipse.

Comment inclure du Swing dans une application SWT et inversement ?

Auteurs: Lunatix , Laurent.B , Gueritarish,

Pour inclure du Swing dansdu SWT, voici un exemple Snippet154.java.
Pour incluredu SWT dansdu Swing, c'est cet exemple qu'il faut observer Snippet337.java.
Vous avez quelques autres exemples dansla partie Swing/AWT de cette page SWT Snippets.

Pourquoi mon widget qui hérite d'un widget SWT plante al'exécution ?

IAuteurs: Lunatix , Laurent.B,

Il est fortement déconseillé d'hériter d'un widget SWT .

En effet, méme s SWT est une API Java, les objets quel'on utilise ne sont que des représentations du code natif d'un
toolkit graphique. Defait, I'héritage n'est pas forcément supporté (Gtk est codé en C par exemple).

En conséquence, chaque widget (sauf bien sir 'Composite’) utilise un mécanisme pour bloquer I'héritage : la une

méthode protected void check Subclass() throws SWTException. Cf. Iaﬁ\]avadoc.

Peut-étre vous posez-vous la question de savoir pourquoi le mot cléfinal n'a pas été utilisé dans ce genrede cas ?

Tout simplement par ce quele systéme de check au runtime n'empéche pas|'héritage. Ce qui fait qu'en cas de nécessité,
il suffit de surcharger cette méthode dans votre classe.

Cependant, en choisissant cette option, vous vous exposez a des problémes de non portabilité car si votre widget hérité
fonctionne sur une plate-forme, il peut ne pas fonctionner sur une autre. Donc, a vous de savoir si ¢a vaut le coup de
passer par I'héritage.

L'utilisation de ce mécanisme est a réserver pour faire du BugFix, sans attendre que cela soit intégré a la distribution
officiellede SWT. Il nefaut passen servir en revanche pour ajouter desfonctionnalités.

En clair, pasd'héritage de widget en SWT. La solution est d'utiliser la composition.

Auteurs: Lunatix ,

Laprésence deslibrairies nativesde SWT va vousforcer asigner vosjar afin de pouvoir sortir de la Sandbox de Java
Web Start.
Pour cela, il faut préparer un jar devotreapplication (myApp.jar), unjar avecleslibrairiesnatives(swt_win32.dll sous
Windows) que I'on va nommer swt-nativejar et avoir sousla main swt.jar.
génération du certificat
1 keytool -genkey -keystore myKeyStore -alias myKey : pour générer votre propre certificat
Donnez a myKeyStore le nom que vous voulez pour votre keyStore
Donnez a myKey le nom que vous voulez pour votre clé key
Répondez aux questions en n'oubliant pasle mot de passe et repondez yes a la derniére question.
2 Ensuite: keytool -selfcert -alias myKey -keystore myKeyStore (attention au mot de passe)
3 Et pour finir
jarsigner.exe -keystore myK eyStor e -verbose -certs swt.jar myKey
jarsigner.exe -keystore myK eyStore -verbose -certs swt-nativejar myKey
jarsigner.exe -keystore myK eyStor e -verbose -certs myApp.jar myKey
4 Faire également de méme avec toutesvoslibrairies (jfacejar, ...).

Puis comme fichier .jnlp
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<?xm version="1.0" encodi ng="utf-8"?>
<jnlp spec="1.0+" codebase="http://ww. donai ne. conml application" href="nyApp.jnlp">
<i nformation>
<title>myApp</title>
<vendor >Lunati x corporation inc</vendor>
<honepage href="http://ww. donai ne. com "/ >
<descri pti on>nmyApp</ descri pti on>
<description ki nd="short">une application de test</description>
</information>
<security>
<al | - per m ssi ons/ >
</security>

<r esour ces>

<j 2se version="1.4+"/>

<jar href="nyApp.jar"/>

<jar href="jface.jar"/>

<jar href="forns.jar"/>

<nativelib href="swt-native.jar"/>
</ resources>

<resour ces os="W ndows">
<jar href="swt.jar"/>
</ resources>
<application-desc main-class="com donai ne. nyApp. MyApp" />
</jnl p>

Pour uneversion plus détaillée, lisez I'articleﬂ Ife.developpez.com/Java/SWT/WebStart/ de LFE.

[2.X] Comment afficher un calendrier ou un sélecteur de date en SWT ?

Auteurs: Lunatix ,

Il n'y a pasdecalendrier ni dewidget dédié aux datesdans SWT. Il faut donc utiliser deslibrairies supplémentaires
“SVVTCaIendar
HS\NT DatePicker

[3.3+] Comment afficher un calendrier ou un sélecteur de date en SWT ?

Auteurs: djo.mos,

Depuislaversion 3.3, un composant de sélection de date/temps a été intégré au jeu de composants standard de SWT.
C'est lewidget H DateTime

Voici un exemple de son utilisation :

Dat eTi ne cal endar = new Dat eTi ne (shell, SW.CALENDAR);
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DateTine time = new DateTine (shell, SW.TIM);

Auteurs: Mickael Baron ,
Suiteaun clicsur lacroix defermetured'unefenétre (Shell), celle-ci est " disposée” et par conséquent fermée. Lafenétre
n'est pas simplement rendue invisible, ses ressour ces sont effectivement libérées, via un appel implicite de la méthode
dispose().

Pour empécher de "disposer” une fenétre a sa fermeture, il suffit de placer un écouteur sur |'événement ShellEvent
et traiter la méthode shellClosed(). L'événement ShellEvent véhicule un flag appelé doit dont leréle est d'indiquer si
I'opération en cours(fermeture, iconification, ...) doit éreachevéeou pas. Dansnotrecas, il suffit demettreleflag afaux.
Par ailleurs, onrend lafenétre Shell invisibleen appelant saméthode setVisible() avec falseet on préserveainsi I'instance

delafenétre, pour notamment la faireréapparaitre lor sque nécessaire.

shel | . addShel | Li st ener (new Shel | Adapter () {
/**
* @ee org.eclipse.sw.events. Shel | Adapt er#shel | Cl osed(org. eclipse.swt. events. Shel |l Event)
*/
@verride
public void shell d osed(Shell Event event) ({
// On neutralise |'événenent
event.doit = fal se;
// Onrend la fenétre invisible
((Shell) event.getSource()).setVisible(false);

}
1)
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[3.4+] Comment utiliser Subversion (SVN) dans Eclipse ?
Auteurs: djo.mos, Laurent.B,

Deux plug-ins existent Subclipse et Subversive.

Lepremier est delasociété Tigris (éditeur de Subversion) et le second est de la société Polarion.

En plusd'évoluer sans cesse, ces plug-insont chacun leurs particularités, ce qui lesrend difficiles a départager.

Le mieux éant de sefaire sa propreopinion en lestestant tous les deux, tout en évitant delesinstaller en mémetemps.

Cesdeux plug-inssiinstallent de facon classique a I'aide du Gestionnaire de Misesa Jour (Cf. Installation d'un plug-in
avec [3.4] Comment installer un plug-in ? ou [3.5] Comment installer un plug-in ? si besoin).

Pour installer Subversive, voir la Q/R [3.4+] Comment installer le client SVN Subversive ?

Pour installer Subclipse, voir la Q/R [3.2+] Comment installer le client SVN Subclipse ?

[3.4+] Comment installer le client SVN Subversive ?

Auteurs: djo.mos, Laurent.B,

Depuislaversion 3.4, Subversive fait désormais partie des projets Eclipse.
Il est composé de deux parties, la premiére qui permet d'utiliser les différentes fonctionnalités SVN et la seconde
partie qui permet de connecter Eclipse a un serveur SVN. Cette derniére étant toujours maintenue directement
par Polarion (Cf. http://community.polarion.com/index.php?page=over view& proj ect=subver sive pour de plus amples
renseignements).
1ereétape: Ajouter lesupdate-sites des deux parties de Subversive, viale Gestionnaire de Mises a Jour de Eclipse (Cf.
Installation d'un plug-in avec [3.4] Comment installer un plug-in ? ou [3.5] Comment installer un plug-in ? si besoin).
. Galileo (3.5) :
. L'environnement : il est déa référencé par défaut, dans le menu "Help > Install New Software...",
en séectionnant " Galileo - http://download.eclipse.org/release/galileo”, puis en ouvrant la rubrique
" Collaboration Tools"
. Les connecteurs: http://community.polarion.com/pr oj ects/subver sive/download/eclipse/2.0/galileo-site/
. Ganymede (3.4) :
. L'environnement : http://download.eclipse.or g/technology/subver sive/0.7/update-site/
. Les connecteurs: http://community.polarion.com/pr oj ects/subver sive/download/eclipse/2.0/update-site/
2tme étape: Sélectionner les modulesréellement nécessaires par mi tous ceux proposés.
. Lepremier module a sélectionner est celui qui sintitule"” Subversive SYN Team Provider (incubation)".
. L e deuxieme module a sélectionner est un des connecteurs disponibles, lequel doit ére adapté au serveur SVN
quevous utilisez, ainsi qu'a votre environnement de développement.
Si vousignorez lequel sélectionner, le plus ssimple étant de cocher tous les connecteurs présents dansla rubrique
" Subversive SVN Connectors' car detoute maniére, il est ensuite possible de sélectionner le connecteur le mieux
adapté, au niveau des préférencesd'Eclipse, danslemenu " Team > SVN" et I'onglet " SVN Connector" .

Unefoisles plug-ins sélectionnés, il suffit devalider I'installation et laisser Eclipseredémarrer.

Remar que: Lesupdate-sitesquevousvenez d'ajouter proposent différents modules complémentair es, telsque ceux qui
contiennent le code sour ce de Subver sive ou ceux qui per mettent son intégration dans d'autr es plug-ins comme Mylyn,
Buckminster et ProjectSet. Si vous vous demandez a quoi ils peuvent servir, c'est probablement que vous pouvez vous
abstenir delesinstaller car ilsnevousseront pas utiles.

Si votreversion de Eclipse est antérieurealaversion 3.4, il reste possible d'installer le plug-in Subversive.
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Pour cela, reportez-vous au lien suivant B http://community.polarion.com/index.php?
page=download& project=subversive

Auteurs: djo.mos, Laurent.B,

1¢€ étape : Ajouter un des update-sites de Subclipse, via le Gestionnaire de Mises a Jour de Eclipse (Cf. Installation
d'un plug-in avec [3.4] Comment installer un plug-in ? ou [3.5] Comment installer un plug-in ? si besoin).
LesversionsrécentesdeEclipse, deCallisto (3.2) aGalileo (3.5), partagent lesmémesURL en cequi concernelesupdate-
sites a ajouter pour Subclipse.
En revanche, il existe plusieursupdate-sites selon la version de Subclipse. A vous de choisir celle qui convient le mieux
par rapport au serveur SVN auquel vous souhaitez connecter vos projets.
. Subclipse 1.6.x (pour SVN 1.6.X) : http://subclipsetigris.org/update 1.6.x
. Subclipse 1.4.x (pour SVN 1.5.X) : http://subclipsetigris.org/update 1.4.x
2tme étape: Sélectionner les modules nécessair es par mi ceux proposes.
. Apreésavoir ajouté un des deux update-sites, uneliste de 8 ou 9 modules appar ait.
A moins de savoir précisément ce dont vous avez besoin, sélectionnez-les tous, de cette maniére vous n'oublirez
rien.

Unefoisles plug-ins sélectionnés, il suffit devalider I'installation et laisser Eclipseredémarrer.

Remarque : Pour fonctionner, Subclipse nécessite soit le module JavaHL (Java High Level) qui Sappuye sur les
bibliothéques natives du client SVN installé sur le poste, soit le module SVYNKit qui lui est codé en Java et qui n'a pas
besoin de client SVN préinstallé. Donc vous I'aurez compris, Si vous n'avez pas installé préalablement de client natif
pour utiliser SVN, que ce soit leclient en lignede commande ou leclient graphiquetel que Tortoise, vous serez contraint
d'utiliser lemodule SVNKit car lemoduleJavaHL nefonctionnerapas. Tigrisdit s efforcer demaintenir lesAPI natives
et SVNKit au méme niveau, donc que Subclipse fonctionne a I'aide deI'un ou de l'autre, le niveau des fonctionnalités
devrait théoriguement étrele méme.

Le choix entre les deux modes se fait au niveau des préférences de Eclipse, dans le menu " Window > Preferences >
Team > SVN", puisdans bloc " SVN Interface", vous pouvez sélectionner le client JavaHL (INI) ou le client SVNKit
(pure Java).

L esliens suivants pourront vous étre utiles pour de plusamplesrenseignements:
- Référentiel desupdate-sitesde Subclipseﬁ http://subclipse.tigris.or g/ser vlets/Pr oj ectPr ocess?pagel D=p4wY uA.

- Les particularités concernant Windows 64 bits, OS X et Linux, ainsi que diverses autres explications ﬁ http://
subclipse.tigris.org/wiki/JavaHL .

Comment configurer Eclipse pour fonctionner avec CVS ?

Auteurs: Lunatix ,

Ouvrir la perspective CVS, puis dans la vue CVS repositories > bouton droit > new repository location > ouverture
del'assistant de connexion.
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Unefoisquevotrerepository est bien renseigné, vous pourrez naviguer dedans dans|'ar bor escence.

Comment extraire un projet sous CVS ?

Auteurs: Lunatix ,

Ouvrezlaperspective CVS, puisdansvotrerepository CVS, choisissez cequevousvoulez pour lecheckout. faitesbouton
droit > check out as > java project

Comment changer un projet de repository CVS ?

Auteurs: Lunatix ,

Pour changer la localisation de votre cvs, allez dans les propriétés du projet : CVS > change sharing > choisissez un

autrerepository
Cedeuxieme serveur CVSdoit déja étre configur € dansla per spective CVS, et doit étre compatible avec votre projet.

| Autres systemes de gestion de version ? |

Auteurs: Lunatix , Laurent.B,

Pour gérer d'autres gestionnairesde version il vousfaudrainstaller desplug-ins supplementaires.
Subversion : ﬁSubcIipse

ClearCase: B& M Rational Clear Case plug-ins

vss: Bl vss Plugin

Auteurs: Lunatix , Laurent.B,

Eclipse, en plus de pouvoir utiliser CVS (ou autre) dispose d'un repository interne. Pour y acceder, il suffit sur un
fichier (dans|'éditeur ou dansle package explorer) de faire bouton droit > compare with local history pour visualiser
les differences

bouton droit > replace from local history pour remplacer lefichier

Remarque : afin d'éviter quelques surprises telles que I'absence d'historique pour un fichier en particulier ou des
versions non conserveées car trop anciennes, il peut étre intéressant de modifier quelques paramétres dans le menu
"General / Workspace/ Local History" des préférencesd'Eclipse. Ainsi, on peut indiquer la durée de conservation, le
nombre de modifications a conserver et lataille desfichiersa prendre en compte.

A noter toutefoisquetout ceci n'arien de pérenne et neremplacera pasun véritable gestionnaire de versions.
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Auteurs: djo.mos,

Basiquement, un plug-in au sens d'Eclipse est un ou plusieursfichiersjar qui peuvent agir sur Eclipse en ajoutant de
nouvelles fonctionnalités, per spectives, vues, etc.

Techniquement, un plug-in au sensd'Eclipse est un bundle OSGi qui peut agir sur Eclipse:

. En exportant des packages (au sensd'OSGi) ce qui permet a d'autres plug-insd'utiliser les classes qu'il exporte.
. En utilisant des points d'extension définies par d'autres plug-ins.

. En exposant des points d'extension que d'autres plug-ins pourront utiliser.

Pour développer des plug-ins pour Eclipse, on utilise Eclipse lui-méme, ou plus précisément le tooling PDE (Plug-in
Development Tools).

Auteurs : Jfrancoiss7 ,

C/C++ I DE - Graphical Editor Framework (GEF) Project - COBOL - UM Lzﬁeclipse.org/tools/
Site généralisteﬁeclipsepluginsZy.net
Site généralisteﬁeclipseplugincentral

[3.3-] Comment installer un plug-in ?

Auteurs: Jfrancoiss7 , djo.mos, Laurent.B,

Voici les différentesfagons d'installer un plug-in dans Eclipse 3.3 et versions antérieures:

L orsquele plug-in se présente sous la forme d'un fichier compressé (zip ou tar)

. Téléchargez lefichier

. Décompressez lefichier zip ou tar

. M ettrerespectivement lesfichiers/pluginsdanslerépertoire/eclipse/pluginset lesfichier s/features dans/eclipse/
features (Sil y a également des features)

. Redémarrez Eclipse

Lorsguele plug-in se présente sous la forme d'une adr esse web (update site)

. Ouvrez Eclipse

. Allez dansle menu Help / Software Updates/ Find and I nstall

. Séectionnez Search for new featuresto install

. Cliquez sur New Remote Site, donnez lui un nom (il seraidentifié ainsi danslaliste) et entrez I'URL

. Cliquez sur Next, et continuez jusqu'au bout du processus en acceptant toutes les demandes

. Eclipse devrait télécharger et installer automatiquement le plug-in aprés avoir cliqué sur Install. Le programme
vous demande ensuite deredémarrer. Cliquez sur Yes

L orsquele plug-in se présente sous la forme d'un update-site ar chivé
. Téléchargez lefichier

. Décompressez lefichier zip ou tar

. Ouvrez Eclipse

. Allez dansle menu Help / Software Updates/ Find and I nstall
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. Séectionnez Search for new featuresto install

. Cliquez sur New L ocal Siteet indiquez I'emplacement del'ar chive extraite, puisdonnez un nom pour I'udpate site

. Cliquez sur Next, et continuez jusqu'au bout du processus en acceptant toutes les demandes

. Eclipse devrait installer automatiquement le plug-in aprésavoir cliquésur Install. Le programme vous demande
ensuitederedémarrer. Cliquez sur Yes

[3.4] Comment installer un plug-in ?

Auteurs: Jfrancoisb7 , djo.mos, Laurent.B,

Voici les différentesfagons d'installer un plug-in dans Eclipse Ganymede (3.4) :

L orsguele plug-in se présente sous la forme d'une adr esse web, appelée " update-site"

. Ouvrez Eclipse

. Allez dansle menu Help / Softwar e Updates puis dans la section Available Software

. Cliquez sur Add Site, entrez I'URL et validez

. Localisez le nouveau site danslaliste, déroulez-le et cochez les composants qui vous intér essent.

. Cliquez sur le bouton Install

. Eclipse installe alors automatiquement le(s) plug-in(s). Le programme vous demande ensuite de redémarrer.
Cliquez sur Yes

Lorsguele plug-in se présente sousla formed'un fichier compressé (zip ou tar)

. Téléchargez lefichier

. Décompressez lefichier zip ou tar

. Mettrerespectivement lesfichiers/pluginsdanslerépertoire/eclipse/pluginset lesfichiers/featuresdans/eclipse/
features (sil y a également desfeatures)

. Redémarrez Eclipse

Lorsque le plug-in se présente sous la forme d'un fichier compr essé (zip) 22™M€ méthode

. Téléchargez lefichier

. Déposer lefichier danslerépertoiredropins (présent alaracinedu répertoired'installation d'Eclipse)
. Démarrer ou redémarrer Eclipse

L orsguele plug-in se présente sous la forme d'un update-site archivé

. Téléchargez lefichier

. Ouvrez Eclipse

. Allez dansle menu Help / Softwar e Updates puis dans la section Available Software

. Cliquez sur Add Site, puissur Archive. Localisez I'archive et validez

. Cliquez sur le bouton Install

. Eclipse installe alors automatiquement le(s) plug-in(s). Le programme vous demande ensuite de redémarrer.
Cliquez sur Yes

Auteurs: Jfrancoiss7 , djo.mos, Laurent.B,

Voici les différentesfagons d'installer un plug-in dans Eclipse Galileo (3.5) :

L orsguele plug-in se présente sous la forme d'une adr esse web, appelée " update-site"

. Ouvrez Eclipse

. Allez dansle menu Help / Install New Software... puis cliquez sur le bouton Add....

. Dansla fenétre qui s'est ouverte, laissez vide ou donnez le nom que vous voulez a I'update-site que vous étes en
train d'ajouter, renseignez son URL, puisvalidez.
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. L'update-site que vousvenez d'ajouter seretrouve automatiquement sélectionnédanslaliste” Work with" . Vous
pouvez donc cocher les différents plug-ins qui vous intéressent parmi la liste proposée.

. Cliquez sur Next une premieérefois, puisune deuxiéme si aucune erreur de dépendance n'est signalée.

. Acceptez leslicences, puis cliquez sur Finish.

. Comme recommandé, redémarrez Eclipse.

Lorsquele plug-in se présente sous la forme d'un fichier compressé (zip ou tar)

. Téléchargez lefichier

. Décompressez lefichier zip ou tar

. Mettrerespectivement lesfichiers/pluginsdanslerépertoire/eclipse/pluginset lesfichiers/featuresdans/eclipse/
features (sil y a également desfeatures)

. Redémarrez Eclipse

Lorsque le plug-in se présente sous la forme d'un fichier compr essé (zip) 22™M€ méthode

. Téléchargez lefichier

. Déposer lefichier danslerépertoiredropins (présent alaracinedu répertoired'installation d'Eclipse)
. Démarrer ou redémarrer Eclipse

L orsquele plug-in se présente sous la forme d'un update-site ar chivé

. Téléchargez lefichier

. Ouvrez Eclipse

. Allez dansle menu Help / Install New Software... puis cliquez sur le bouton Add....

. Dansla fenétre qui s'est ouverte, laissez vide ou donnez le nom que vous voulez a I'update-site que vous étes en
train d'ajouter.

. Cliquez sur Archive, puislocalisez I'archive et validez

. L'update-site que vousvenez d'ajouter seretrouve automatiquement sélectionnédanslaliste" Work with" . Vous
pouvez donc cocher les différents plug-ins qui vous intéressent parmi la liste proposée.

. Cliquez sur Next une premiérefois, puis une deuxiemesi aucune erreur de dépendance n'est signalée.

. Acceptez leslicences, puis cliquez sur Finish.

. Commerecommandé, redémarrez Eclipse.

[3.6+] Comment installer un plug-in ?

IAuteurs: Laurent.B ,

Lafacon defaireaveclaversion d'Eclipse 3.5 reste valable pour tousles plug-ins (Cf. [3.5] Comment installer un plug-
in?).

Cependant, depuis Eclipse 3.6, il existe un nouveau moyen, lequel consiste a passer par I'Eclipse MarketPlace.

Cela concerneles plug-ins et outils de sociétés ou contributeurstiers, quel'on peut alorsinstaller directement a partir
d'Eclipse.

Donc, alamaniérede ce qui sefait dansd'autreslogiciels, il est & présent possible derechercher un plug-in ou un outil
puisunefoistrouvé, del'installer par un simpleclic.

Par exemple, si vous voulez installer le plug-in pour Maven 2, allez dans le menu Help > Eclipse Marketplace..., puis
saisissez maven 2 dansla case Find dela fenétre qui s est ouverte.

Validez en appuyant sur Entrée et en principe, le premier résultat devrait correspondre a Maven 2.

I vous suffit alorsde cliquer sur son bouton Install et de suivrelesinstructions.

Veuillez noter quetouslesplugins du MarketPlace ne sont pas forcément installables directement.
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Parfoisvousn'aurez paslebouton Install et il faudra aller sur lesitedel'éditeur pour pouvoir lerécupérer.

IAuteurs: Jfrancoiss7, Laurent.B ,

Si votre configuration réseau le nécessite, vous avez la possibilité de configurer un proxy afin qu'Eclipse puisse accéder
aInternet.

La configuration s effectue a partir du menu :

Window > Preferences > Install-Update, cocher la case "Enable HTTP Proxy connection" puis, compléter les
paramétres"HTTP proxy host address' et "HTTP proxy host port"”.

[3.3+] Comment configurer le proxy dans Eclipse ?

Auteurs: Jfrancois57 , Laurent.B,

alnternet.
La configuration s effectue a partir du menu :

Si votre configuration réseau le nécessite, vous avez la possibilité de configurer un proxy afin qu'Eclipse puisse accéder
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Window > Preferences > General > Network Connections >, cocher la case "Manual proxy configuration" puis,
compléter I'adresse "HTTP Proxy" et le numéro de "Port". A noter que les versions récentes d'Eclipse offrent un
certain nombrede paramétres supplémentairestelsquela configuration SSL / SSH2/ SOCKS, |'authentification, ...etc.

[2.X] Comment savoir S un plug-in est intégré/installé dans Eclipse ?

Auteurs: zsoh ,

Pour vair laliste des plug-ins: cliquez sur le menu > Aide > A propos et onglet Détails des plug-ins

[3.X] Comment savoir si un plug-in est intégré/installé dans Eclipse ?

Auteurs: djo.mos,

Pour voir la liste des plug-ins : cliquez sur le menu > Help > About Eclipse Platform puis sur le bouton onglet Plug-
in Details

Pourquoi mon plug-in n'apparait pas dans les perspectives ?
Auteurs: L'équipe Eclipse,

Il arrive que la détection d'un nouveau plug-in se passe mal. Dans ce cas, il vous suffit de redémarrer Eclipse avec
I'option -clean pour forcer la détection des plug-ins. Ne laissez pas cette option, car cela ralenti considérablement le
démarrage.

| Quels sont les langages que peut gérer Eclipse en plus de Java ? |

Auteurs: Lunatix , djo.mos, Laurent.B,

Grace a son architecture modulaire et a I'ajout de plug-ins complémentaires, Eclipse peut gérer un grand nombre de
langages. Cetteliste n'est pas exhaustive et tousles plug-ins ne sont pas de qualité équivalente.
langages et plugins

C/C++ : Plug-in officiel : ﬁwww.eclipse.org/cdt/
*  Cobol : Plug-in officiel :Fl@ www.eclipse.or g/cobol/

DLTK : Plug-in officiel qui offrele support de Tcl, Ruby et Python : “http://www.eclipse.org/dltk/
Php : Plug-in officiel PDT “www.eclipse.org/pdt ou PH PEcIipse“www.phpeclipse.de

Python : “ pydev

Latex : ﬁTeinpse

Perl : ﬁep-i-c.sourceforge.net/

C#: ﬂ improve-technologies esharp, H Emonic
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Ruby : ﬁrubyeclipse

Comment faire une interface graphique sous Eclipse ?
Auteurs: Lunatix , djo.mos, Laurent.B,

Peut-étre I'aur ez-vous remar qué mais par défaut, Eclipse ne propose pas d'outil permettant de créer des interfaces
graphiques de maniérevisuelle.
Heureusement, il existe des plug-ins pour pallier a ce manque.

ﬁVisuaI Editor Project (VEP) : le plug-in officiel, gratuit, gérant Swing et SWT mais qui n'évolue plus et dont
la pérennité est largement compromise.

EVisuaI Swing for Eclipse gérant Swing.
EJigloo Gratuit pour usage non professionnel, gérant Swing et SWT.

Et surtout : Bl Window Builder Pro donné par Google (code source et propriété intellectuelle compris), a la
fondation Eclipse (décembre 2010)!
Il integre SWT Designer, Swing Designer et GWT Designer.

Comment installer le Visua Editor (VE) ?

IAuteurs: Lunatix , djo.mos, Laurent.B ,

Avant toute chose, Visual Editor étant dans un état végétatif depuis longtemps, vous aurez tout avantage a vous
intéresser plutdt aHWindow Builder Pro, donné a la fondation Eclipse par Google.

HVE est le plug-in officiel pour le développement d'interface graphique pour Eclipse. Vous pouvez l'installer trés
simplement via I'Update Manager.

Menu Help > Softwar e updates > find and I nstall > Search for new featurestoinstall > deployez Eclipse.org update site
> sélectionnez EMF, GEF, and Visual Editor update sites > choisissez Visual Editor : la Eclipse va vous indiquer les
versionsde EMF et GEF compatibles. || ne vousreste plus qu'a accepter leslicenses et valider I'installation.

Veuillez noter qu'officiellement VE supporteuniquement Eclipse 3.2 (Callisto) maisqu'il est possibledel'installer dans:
Eclipse 3.1.2 en suivant Hcette procédure
Eclipse 3.3 et 3.4 en suivant ﬁcette procédure
L e Eclipse NewsPortal H Newsgroup

Leprojet VEP n'évolue plusdepuisun certain temps. Seulesquelques per sonnessemblent vouloir au moinsle maintenir
pour qu'il reste compatible avec les ver sions plus récentes d'Eclipse.

D'autre part, lafondation Eclipse s étant vue offrir I'outil Windows Builder Pro par Google, il devient par conséquent
inutile de persévérer avec VEP.

Comment g outer un composant au Visual Editor (VE) ?

Auteurs: guipom , Laurent.B,

/"\ Lien obsoléte inexploitable ...

Vous pouvez lireletutoriel suivant : ‘
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http://dev.eclipse.or g/viewcvs/indextools.cgi/% 7Echeck out% 7E/or g.eclipse.ve.examples/
or g.eclipse.ve.example.customwidget/WebContent/index_filesmain.htm "Extending The Visual Editor Tutorial:
Enabling support for a custom widget"
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